Last Comment Bug 674229 - Repeat bubbles in Web Console are too close to the Source Link
: Repeat bubbles in Web Console are too close to the Source Link
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 8
Assigned To: Rob Campbell [:rc] (:robcee)
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 08:12 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-07-30 21:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot OS X (14.21 KB, image/png)
2011-07-26 08:12 PDT, Rob Campbell [:rc] (:robcee)
no flags Details
Packed (994 bytes, patch)
2011-07-26 19:11 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review-
Details | Diff | Splinter Review
unpacked (2.53 KB, patch)
2011-07-27 11:07 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review-
Details | Diff | Splinter Review
screenie (15.48 KB, image/png)
2011-07-27 11:08 PDT, Rob Campbell [:rc] (:robcee)
no flags Details
new screen, no width in bubble, 10em on source link (16.55 KB, image/png)
2011-07-28 05:17 PDT, Rob Campbell [:rc] (:robcee)
no flags Details
[in-fx-team] unpacked, unwidthed (1.54 KB, patch)
2011-07-28 05:18 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review+
mihai.sucan: review+
bugzilla: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-07-26 08:12:28 PDT
Created attachment 548463 [details]
Screenshot OS X

The repeat bubbles in the web console are running into the source link area in the web console. See attached screenshot.
Comment 1 Rob Campbell [:rc] (:robcee) 2011-07-26 19:11:34 PDT
Created attachment 548662 [details] [diff] [review]
Packed

added pack="end" to the repeated nodes to ensure adequate spacing is retained.
Comment 2 Dão Gottwald [:dao] 2011-07-26 19:16:06 PDT
width:1em on the label is causing this problem, isn't it? Why is this applied in the first place?
Comment 3 David Dahl :ddahl 2011-07-26 19:53:58 PDT
(In reply to comment #2)
> width:1em on the label is causing this problem, isn't it? Why is this
> applied in the first place?

In the CSS, I removed the width from the node and from the 'webconsole-location' node, and got this result:
http://img840.imageshack.us/img840/4610/selection028g.png
Comment 4 Dão Gottwald [:dao] 2011-07-27 00:55:37 PDT
Comment on attachment 548662 [details] [diff] [review]
Packed

So if I understand it correctly, comment 3 confirms that width:1em isn't needed and removing it fixes this bug.
Comment 5 Rob Campbell [:rc] (:robcee) 2011-07-27 05:54:44 PDT
the spacing looks a little tight around that source link, but at least it's not bleeding into it.

No idea why there's a 1em width on this, I don't remember.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-07-27 11:07:11 PDT
Created attachment 548834 [details] [diff] [review]
unpacked

removed the pack attribute and excised the widths from both the source link and repeat bubbles. Result fits at least, but the bubbles are right aligned with the left edge of the source.
Comment 7 Rob Campbell [:rc] (:robcee) 2011-07-27 11:08:02 PDT
Created attachment 548835 [details]
screenie
Comment 8 Dão Gottwald [:dao] 2011-07-27 12:31:18 PDT
Comment on attachment 548834 [details] [diff] [review]
unpacked

(In reply to comment #6)
> Result fits at least, but the bubbles are right aligned
> with the left edge of the source.

That's because you removed width:10em from .webconsole-location, which seems wrong... It's probably going to prevent the location from being cropped too.
Comment 9 David Dahl :ddahl 2011-07-27 12:37:17 PDT
(In reply to comment #8)
> That's because you removed width:10em from .webconsole-location, which seems
> wrong... It's probably going to prevent the location from being cropped too.

What would be the ideal solution here? just remove the 1em width on the repeat bubble nodes? I was tinkering with it in DOMInspector and I thought the overlap was still there with just the 'width:1em' removed.
Comment 10 Dão Gottwald [:dao] 2011-07-27 12:50:59 PDT
(In reply to comment #9)
> I was tinkering with it in DOMInspector and I thought
> the overlap was still there with just the 'width:1em' removed.

That's not what I see.

Also, do you know what change caused this problem? This seems to be a recent regression.
Comment 11 Rob Campbell [:rc] (:robcee) 2011-07-27 14:12:49 PDT
(In reply to comment #10)
> (In reply to comment #9)
> > I was tinkering with it in DOMInspector and I thought
> > the overlap was still there with just the 'width:1em' removed.
> 
> That's not what I see.
> 
> Also, do you know what change caused this problem? This seems to be a recent
> regression.

yeah, it's a regression from bug 662807. align="start" seems to have compressed the layout of these nodes.

I'll re-add the width to the .webconsole-location and resubmit with a screenshot.
Comment 12 Rob Campbell [:rc] (:robcee) 2011-07-28 05:17:04 PDT
Created attachment 549077 [details]
new screen, no width in bubble, 10em on source link

this looks much better.
Comment 13 Rob Campbell [:rc] (:robcee) 2011-07-28 05:18:14 PDT
Created attachment 549078 [details] [diff] [review]
[in-fx-team] unpacked, unwidthed

With the width of the source link readded, this looks much better. Thanks!
Comment 14 Rob Campbell [:rc] (:robcee) 2011-07-29 08:37:45 PDT
Comment on attachment 549078 [details] [diff] [review]
[in-fx-team] unpacked, unwidthed

moving review to mihai to get this checked in.
Comment 15 Mihai Sucan [:msucan] 2011-07-29 09:12:59 PDT
Comment on attachment 549078 [details] [diff] [review]
[in-fx-team] unpacked, unwidthed

Good to go!
Comment 16 Dão Gottwald [:dao] 2011-07-29 09:51:08 PDT
(In reply to comment #14)
> Comment on attachment 549078 [details] [diff] [review] [diff] [details] [review]
> unpacked, unwidthed
> 
> moving review to mihai to get this checked in.

FYI, I'm the owner of toolkit/themes/.
Comment 17 Rob Campbell [:rc] (:robcee) 2011-07-29 10:36:35 PDT
(In reply to comment #16)
> (In reply to comment #14)
> > Comment on attachment 549078 [details] [diff] [review] [diff] [details] [review] [diff] [details] [review]
> > unpacked, unwidthed
> > 
> > moving review to mihai to get this checked in.
> 
> FYI, I'm the owner of toolkit/themes/.

I know. I just wanted signoff from a devtools peer too.

Thanks for the reviews, all!
Comment 18 Rob Campbell [:rc] (:robcee) 2011-07-29 12:37:50 PDT
Comment on attachment 549078 [details] [diff] [review]
[in-fx-team] unpacked, unwidthed

http://hg.mozilla.org/integration/fx-team/rev/e2e7b2275ade
Comment 19 Tim Taubert [:ttaubert] 2011-07-30 21:43:40 PDT
http://hg.mozilla.org/mozilla-central/rev/e2e7b2275ade

Note You need to log in before you can comment on or make changes to this bug.