Last Comment Bug 674261 - autoconfig aka MCD broken
: autoconfig aka MCD broken
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: General (show other bugs)
: 5 Branch
: All Other
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 10:06 PDT by Jehan Procaccia
Modified: 2011-07-27 00:24 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jehan Procaccia 2011-07-26 10:06:46 PDT
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622105737

Steps to reproduce:

configured autoconfig/MCD for thunderbird5 as described in:
https://developer.mozilla.org/index.php?title=en/MCD%2C_Mission_Control_Desktop_AKA_AutoConfig


Actual results:

autoconfig did not applied

From https://bugzilla.mozilla.org/show_bug.cgi?id=502597

I confirm that prefcalls.js in in the a jar now:

# jar -tvf /usr/lib/thunderbird-5.0/omni.jar  | grep prefcalls.js
  7499 Fri Jun 24 20:23:08 CEST 2011 defaults/autoconfig/prefcalls.js

So I tried to used autoconfig as usual:

call to thunderbird.cfg

[root@calaz pref]# pwd
/usr/lib/thunderbird-5.0/defaults/pref
[root@calaz pref]# cat tb-autoconf.js 
// SYNTAX HINTS:  dashes are delimiters.  Use underscores instead.
//  The first character after a period must be alphabetic.

// Jehan
pref("general.config.obscure_value", 0); // for MCD .cfg files
pref('general.config.filename', 'thunderbird.cfg'); // for MCD .cfg files

the lockPref/defaultPref file thunderbird.cfg

[root@calaz thunderbird-5.0]# pwd
/usr/lib/thunderbird-5.0
[root@calaz thunderbird-5.0]# ls -l thunderbird.cfg 
-rwxr-xr-x. 1 root root 6931 Jul 25 23:27 thunderbird.cfg


Try to debug as much as possible

[testloc@calaz ~]$ export MOZILLA_DEBUG=1
[testloc@calaz ~]$ export NSPR_LOG_MODULES=MCD:5
[testloc@calaz ~]$ export NSPR_LOG_FILE=/tmp/thunderbird-log.txt

Start thunderbird

[testloc@calaz ~]$ rm -rf .thunderbird/
[testloc@calaz ~]$ thunderbird 
-- Exception object --
+ QueryInterface (function) 3 lines
+ message (string) 'Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]'
+ result (number) 2147549183
+ name (string) 'NS_ERROR_UNEXPECTED'
+ filename (string) 'resource:///modules/mailnewsMigrator.js'
+ lineNumber (number) 80
+ columnNumber (number) 0
+ location (object) JS frame :: resource:///modules/mailnewsMigrator.js :: MigrateServerAuthPref :: line 80
+ inner (object) null
+ data (object) null
+ initialize (function) 3 lines

no way to know what went wrong, i don't even know if autoconfig is to blame as I don't have debug information
/tmp/thunderbird-log.txt is empty .

However I supect that autoconfig is responsible, because if I remove the call to thunderbid.cfg by removing file /usr/lib/thunderbird-5.0/defaults/pref/tb-autoconf.js then thunderbird starts without error. So at least autoconfig is probably still alive ... but How can I check what went wrong, how can I trace it's execution ?

Thanks .


Expected results:

it should have feed preferences with default and lock pref described in the thunderbid.cfg file called by default/pref/tb-auto.js .
Comment 1 Mark Banner (:standard8, afk until Dec) 2011-07-27 00:24:43 PDT
Resolving as works for me per bug 502597 comment 44.

Note You need to log in before you can comment on or make changes to this bug.