Closed Bug 674280 Opened 11 years ago Closed 4 years ago

If clusterURL is broken for a long time, check with node server to be certain it's correct

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: Atoll, Unassigned)

References

Details

(Whiteboard: [qa?][sync:scale])

Problem: Once client gets a clusterURL, it engraves it in stone until either a 401 or a deactivate this device.  This prevents recovering from issues where a clusterURL that does not resolve is handed to a client by the node server.

Steps to reproduce:

1. Configure node assignment to give out a broken, does-not-resolve, hostname.
2. Set up sync in Firefox.
3. Sync Now, triggering yellow error bar about bad hostname.
4. Fix node assignment on the server and schedule your user for node reassignment.

BUG: Client never detects that node assignment has changed, because it's impossible to serve a 401 from a bogus hostname.

FIX: Once in a while, either coin-flip random or after several clusterURL errors, try pinging the node assignment server to see if it's got a new clusterURL.
34 new users were affected by a node assignment bug today, leading to their clients being assigned a broken server URL.  We emailed repair instructions to the affected users.
OS: Mac OS X → All
Hardware: x86 → All
Correcting title.

See also Bug 716816 for Android Sync.
Blocks: 742485
Summary: if serverURL is broken for a long time, check with node server to be certain it's correct → If clusterURL is broken for a long time, check with node server to be certain it's correct
Whiteboard: [qa?]
Whiteboard: [qa?] → [qa?][sync:scale]
See Also: → 950476
Closing this ancient Sync bug that hasn't been triaged in 5-7 years since I filed them - either it's not an issue or it's been silently refused by the teams involved.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.