Last Comment Bug 674315 - move test_clear_site_data.html to mochitest-chrome
: move test_clear_site_data.html to mochitest-chrome
Status: RESOLVED FIXED
[specialpowers][inbound]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla8
Assigned To: Joel Maher (:jmaher)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 12:28 PDT by Joel Maher (:jmaher)
Modified: 2011-07-29 03:07 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
move test_clear_site_data.html to mochitest-chrome (1.0) (3.21 KB, patch)
2011-07-26 12:30 PDT, Joel Maher (:jmaher)
dolske: review+
Details | Diff | Review

Description Joel Maher (:jmaher) 2011-07-26 12:28:45 PDT
in working on porting PluginUtils.js to use SpecialPowers, I found that the 2 tests which used it did a lot of interaction which required enabledPrivileges.  I would like to move these from mochitest-plain to mochitest-chrome.
Comment 1 Joel Maher (:jmaher) 2011-07-26 12:30:26 PDT
Created attachment 548547 [details] [diff] [review]
move test_clear_site_data.html to mochitest-chrome (1.0)
Comment 2 Joel Maher (:jmaher) 2011-07-26 12:33:44 PDT
can we verify that this test will still gain the same coverage as a mochitest-chrome and that the patch looks good.
Comment 3 Justin Dolske [:Dolske] 2011-07-27 19:31:51 PDT
Comment on attachment 548547 [details] [diff] [review]
move test_clear_site_data.html to mochitest-chrome (1.0)

In general, I'd be wary of running content stuff in chrome (since that basically never happens in normal usage), but that shouldn't impact anything here. The content part of this test is basically incidental to what it's doing, anyway.
Comment 4 Marco Bonardo [::mak] 2011-07-29 03:07:10 PDT
http://hg.mozilla.org/mozilla-central/rev/02d8eaab6cd3

Note You need to log in before you can comment on or make changes to this bug.