Make the "was the original display inline-level?" check for abs pos elements actually check that, not inline

RESOLVED DUPLICATE of bug 505706

Status

()

Core
Layout: R & A Pos
RESOLVED DUPLICATE of bug 505706
6 years ago
6 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

The current check is |NS_STYLE_DISPLAY_INLINE == mStyleDisplay->mOriginalDisplay|.  Seems like it should be more like the check IsInlineOutside() does.

David, any objections?

Right now Presto has the same behavior we do for inline-block, at least, while WebKit and Trident (IE9) do something like IsInlineOutside().
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505706
You need to log in before you can comment on or make changes to this bug.