All users were logged out of Bugzilla on October 13th, 2018

RPM builds upload pointless non-RPM packages

RESOLVED DUPLICATE of bug 650049

Status

RESOLVED DUPLICATE of bug 650049
7 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Our Linux RPM nightlies are uploading useless and confusingly named tarballs:
/tools/python/bin/python2.5 /builds/slave/m-cen-lnx-rpm-ntly/build/build/upload.py --base-path ../../dist \
		   "../../dist/linux-i686/xpi/mozilla-nightly-8.0a1.en-US.langpack.xpi"  "../../dist/mozilla-nightly-8.0a1.en-US.linux-i686.tests.zip"   "../../dist//mozilla-nightly-8.0a1.en-US.linux-i686.txt" "../../dist/jsshell-linux-i686.zip"   ../../dist/mozilla-nightly-8.0-a1.20110727081800.i686.rpm  ../../dist/mozilla-nightly-tests-8.0-a1.20110727081800.i686.rpm  ../../dist/mozilla-nightly-devel-8.0-a1.20110727081800.i686.rpm \
		"../../dist//mozilla-nightly-8.0a1.en-US.linux-i686.checksums"
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/linux-i686/xpi/mozilla-nightly-8.0a1.en-US.langpack.xpi
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.0a1.en-US.linux-i686.tests.zip
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.0a1.en-US.linux-i686.txt
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/jsshell-linux-i686.zip
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.0-a1.20110727081800.i686.rpm
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-tests-8.0-a1.20110727081800.i686.rpm
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-devel-8.0-a1.20110727081800.i686.rpm
Uploading /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.0a1.en-US.linux-i686.checksums

They shouldn't be. John, any idea how to prevent this?
(In reply to comment #0)
> Our Linux RPM nightlies are uploading useless and confusingly named tarballs:
> /tools/python/bin/python2.5
> /builds/slave/m-cen-lnx-rpm-ntly/build/build/upload.py --base-path
> ../../dist \
> 		   "../../dist/linux-i686/xpi/mozilla-nightly-8.0a1.en-US.langpack.xpi" 
> "../../dist/mozilla-nightly-8.0a1.en-US.linux-i686.tests.zip"  
> "../../dist//mozilla-nightly-8.0a1.en-US.linux-i686.txt"
> "../../dist/jsshell-linux-i686.zip"  
> ../../dist/mozilla-nightly-8.0-a1.20110727081800.i686.rpm 
> ../../dist/mozilla-nightly-tests-8.0-a1.20110727081800.i686.rpm 
> ../../dist/mozilla-nightly-devel-8.0-a1.20110727081800.i686.rpm \
> 		"../../dist//mozilla-nightly-8.0a1.en-US.linux-i686.checksums"
> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/linux-i686/xpi/
> mozilla-nightly-8.0a1.en-US.langpack.xpi
> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.
> 0a1.en-US.linux-i686.tests.zip

Bug 650049

> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.
> 0a1.en-US.linux-i686.txt

Very small, might be useful if tools are written to depend on this file

> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/jsshell-linux-i686.
> zip

Should probably be packaged as well as the Browser and other files

> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.0-
> a1.20110727081800.i686.rpm
> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-
> tests-8.0-a1.20110727081800.i686.rpm
> Uploading
> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-
> devel-8.0-a1.20110727081800.i686.rpm
> Uploading

The RPM files :)

> /builds/slave/m-cen-lnx-rpm-ntly/build/obj-firefox/dist/mozilla-nightly-8.
> 0a1.en-US.linux-i686.checksums

Useful to upload

> They shouldn't be. John, any idea how to prevent this?

The tests zip shouldn't be created but is to ensure that all test files are staged properly.  The JSShell should probably be packaged as well.
Sorry John, I filed this without reading the list of files well enough. Looks like this is a dupe of 650049
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650049
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.