Bug 674804 (css-exclusions-1)

[META] Implement CSS Exclusions Module Level 1

UNCONFIRMED
Unassigned

Status

()

Core
CSS Parsing and Computation
--
enhancement
UNCONFIRMED
6 years ago
23 days ago

People

(Reporter: Aaron Kaluszka, Unassigned)

Tracking

(Depends on: 2 bugs, Blocks: 1 bug, {DevAdvocacy})

Trunk
DevAdvocacy
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome][parity-safari][parity-ie][DevRel:P2], URL)

(Reporter)

Description

6 years ago
Implement Adobe's CSS Exclusions proposal for more complex layouts like those used in print. This is still in flux, but Adobe has created a WebKit-based prototype found here: http://labs.adobe.com/technologies/cssregions/
(Reporter)

Updated

6 years ago
The exclusions proposal has been merged into the floats proposal; I'm against the lot of it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 672053

Comment 2

4 years ago
Exclusions is back, please reopen.

Comment 3

4 years ago
Would you mind reopening, please?
Flags: needinfo?(dbaron)

Comment 4

4 years ago
(In reply to Florian Bender from comment #3)
> Would you mind reopening, please?
I can do that myself now :)

So, according to MSDN, this is already in IE10. Also, Apple showed this on WWDC, and Chrome has it, too. Some tests say Firefox has limited support, but that's mostly for an outdated spec, AFAICS, as the tests linked to in the URL (above) all failed in my Fx 25b.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(dbaron)
Resolution: DUPLICATE → ---
Whiteboard: [parity-chrome][parity-safari][parity-ie]

Comment 5

10 months ago
* Blink Chrome  https://bugs.chromium.org/p/chromium/issues/detail?id=234749 Status: Archived
                https://www.chromestatus.com/features/6296903092273152
* WebKit Safari http://trac.webkit.org/changeset/166618 (Remove exclusions parsing support)
                https://bugs.webkit.org/show_bug.cgi?id=131046
I'd like to discuss Exclusions, and see why folks have been against it. Perhaps the spec needs a new approach. But the end result for Authors would be incredibly helpful. And would stop designers from demanding non-accessible websites are built in order to accomplish their graphic design ideas. NYTimes, MPR, many big editorial sites have broken a11y because they don't have a tool like Exclusions.
Keywords: DevAdvocacy
Whiteboard: [parity-chrome][parity-safari][parity-ie] → [parity-chrome][parity-safari][parity-ie][DevRel:P2]
Turning this into a meta-issue for all the things that are covered by the CSS Exclusions Module Level 1 spec.

Sebastian
Blocks: 1323667
Summary: CSS3 Exclusions → [META] Implement CSS Exclusions Module Level 1
Depends on: 1354485
Depends on: 1354486
You need to log in before you can comment on or make changes to this bug.