Prevent tooltip suppression during drag from breaking tab clicking

RESOLVED FIXED in Firefox 8

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Yann Brelière, Assigned: fryn)

Tracking

Trunk
Firefox 8
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
I clicked and hold a tab, but instead of dragging the tab, it dragged the entire window.
I'm using Ubuntu's default theme, Ambiance, which allows dragging windows from the menubar, and in the case of Firefox, allows dragging the window from the unified tab bar. Except that now, it drags from any tab, not just the background bar.

As long as I don't try dragging a tab, there is no problems, but as soon as I try and fail dragging a tab, I can now no longer even click on a tab to focus it (it grabs and releases the window during the click), and if I right-click on any tab, it displays the toolbar's context menu instead of the tab's.
So if want to be able to pin tabs or switch tabs with the mouse, I have to restart Firefox and refrain from trying to initiate a tab drag.

Related to Bug 455694 and Bug 635397.
(Reporter)

Updated

6 years ago
Blocks: 455694, 635397

Updated

6 years ago
No longer blocks: 635397
(Assignee)

Updated

6 years ago
Assignee: nobody → fryn
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Version: 8 Branch → Trunk
(Assignee)

Comment 1

6 years ago
Created attachment 549055 [details] [diff] [review]
patch
Attachment #549055 - Flags: review?(dao)
Comment on attachment 549055 [details] [diff] [review]
patch

Disabling all pointer events while the user clicks on the tab bar, really? This seems a bit too magical, fragile and like it could have various unforeseen effects (like this bug!). Suppressing tooltips while dragging can be done in createTooltip, right?
Attachment #549055 - Flags: review?(dao) → review-
(Assignee)

Comment 3

6 years ago
Created attachment 549067 [details] [diff] [review]
patch v2

True, but we still need to work around bug 666864.
Attachment #549055 - Attachment is obsolete: true
Attachment #549067 - Flags: review?(dao)
(In reply to comment #3)
> Created attachment 549067 [details] [diff] [review] [review]
> patch v2
> 
> True, but we still need to work around bug 666864.

Well, or talk to the right people to actually get it fixed. (If it's still an issue, then it's no drag-and-drop bug, since you're not using that API anymore.)
(Assignee)

Comment 5

6 years ago
Created attachment 549261 [details] [diff] [review]
patch v3

Oh, oops. Bug 666864 doesn't occur for mouse-event-based operations.
I thought I had reproduced it, but I had accidentally run my build for bug 674925.
Attachment #549067 - Attachment is obsolete: true
Attachment #549067 - Flags: review?(dao)
Attachment #549261 - Flags: review?(dao)

Updated

6 years ago
Attachment #549261 - Flags: review?(dao) → review+
(Assignee)

Comment 6

6 years ago
Pushed to m-c instead of fx-team to get this in the next nightly.

https://hg.mozilla.org/mozilla-central/rev/5bd0acd32308
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Summary: Can't drag tabs anymore on ubuntu → Prevent tooltip suppression during drag from breaking tab clicking
Target Milestone: --- → Firefox 8
You need to log in before you can comment on or make changes to this bug.