[10.7] Firefox 5.0.1 running on Mac OS10.7 returns a Error Code 502 Proxy Error when browsing Web sites

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: support, Unassigned)

Tracking

(Blocks: 1 bug)

5 Branch
Other
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 1.1.4322; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)

Steps to reproduce:

We have installed Firefox 5.0.1 onto a Quad-Core Intel Mac running the new Mac OS 10.7. 


Actual results:

Connecting to the web in our office is thru a Proxy Server. Confirmed that www.adobe.com and www.apple.com websites can be accessed OK.
Confirmed that all other websites generate a "Error Code 502 Proxy Error".
Changing the the Firefox proxy preferences to "Manual proxy Configuration" didn't resolve the issue.



Expected results:

Safari on this machine works without issue connecting to any site. Safari uses the System Preferences/Network Proxy Server settings. We cannot connect to the Mozilla site or the Firefox Add-Ons Manager to download FireFTP
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Other → Mac OS X
Hardware: All → Other
(Reporter)

Updated

7 years ago
Summary: Firefox 5.0.1 running Mac OS10.7 returns a Error Code 502 Proxy Error when browsing Web sites → Firefox 5.0.1 running on Mac OS10.7 returns a Error Code 502 Proxy Error when browsing Web sites
Is Firefox working on other systems in the sane network together with your proxy server ?
Is it possible that you get only 502 errors only with https URLs ?
Please provide a http log and attach it here (use the "add an attachment link" above)
- https://developer.mozilla.org/en/HTTP_Logging#Logging_HTTP_Activity
(Reporter)

Comment 2

7 years ago
Created attachment 549324 [details]
HTTP Log when 502 proxy error occurss
(Reporter)

Comment 3

7 years ago
Thanks Matthias for your reply.
I have attached the log as requested.
I think I should have been more specific with the issue.
We have about 100 macs in our wan. They are running (depending on the site) Mac OS 10.5 or Mac OS 10.6. They all run Firefox 4 or 5. These macs are bound to our AD. They all require proxy authentication. All work perfectly.
I am currently testing 2 Macs in our IT department with Mac OS 10.7. Both these macs are experiencing this problem.

We have actually found a fix with this though.
Typed in about:config into the address bar and changed the setting network.negotiate-auth.allow-proxies to false.
We have previously done this when Firefox repeatedly prompted for proxy authentication or repeatedly for Kerberos authentication.
Is this fixable so that the setting network.negotiate-auth.allow-proxies can be left in the default state of True?
moving over to the network guys and mark it new because we should have all information
Status: UNCONFIRMED → NEW
Component: General → Networking
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → networking
Summary: Firefox 5.0.1 running on Mac OS10.7 returns a Error Code 502 Proxy Error when browsing Web sites → [10.7] Firefox 5.0.1 running on Mac OS10.7 returns a Error Code 502 Proxy Error when browsing Web sites
(Reporter)

Comment 5

7 years ago
We have tried downloading 6.0 but unforunately the issues still exists.

Updated

7 years ago
Blocks: 636455

Comment 6

6 years ago
QA, can you see if we can reproduce? I'm surprised we're not seeing more complaints if this is widespread. If it's real, we should get it in front of necko folks ASAP
Keywords: qawanted
Reporter, does this problem still exist?

QA, anyone try to reproduce?

Comment 8

5 years ago
WFM on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:29.0) Gecko/20100101 Firefox/29.0

Every page I tried loaded without issues.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.