Closed Bug 674917 Opened 9 years ago Closed 2 years ago

Console warning "Use of enablePrivilege is deprecated" when a11y mochitests are running

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: surkov, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Every a11y tests generates warning in error console:

Warning: Use of enablePrivilege is deprecated.  Please use code that runs with the system principal (e.g. an extension) instead.
Source File: chrome://mochitests/content/a11y/accessible/actions/test_anchors.html
Line: 0

a11y mochitests don't call PrivilegeManager explicitly but SimpleTest.js does. I suspect that should be valid for any mochitest (if a11y ones don't have any special handling)
Keywords: access
Mass closing mochitest bugs that haven't had activity in the past 5 years. Please re-open or file a new bug with modern context if this is still relevant.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.