Last Comment Bug 675005 - "ASSERTION: nsWindow::SetParent - reparenting a non-child window"
: "ASSERTION: nsWindow::SetParent - reparenting a non-child window"
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Josh Aas
:
Mentors:
Depends on:
Blocks: 90268
  Show dependency treegraph
 
Reported: 2011-07-28 12:15 PDT by Jesse Ruderman
Modified: 2011-08-25 11:51 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (185 bytes, text/html)
2011-07-28 12:15 PDT, Jesse Ruderman
no flags Details
output with stack traces (15.52 KB, text/plain)
2011-07-28 12:15 PDT, Jesse Ruderman
no flags Details

Description Jesse Ruderman 2011-07-28 12:15:14 PDT
Created attachment 549190 [details]
testcase

1. Apply the patch in bug 90268.
2. Load the testcase.

###!!! ASSERTION: nsWindow::SetParent - reparenting a non-child window: 'Not Reached', file widget/src/gtk2/nsWindow.cpp, line 886

###!!! ASSERTION: Configured widget is not a child: 'w->GetParent() == this', file widget/src/gtk2/nsWindow.cpp, line 4667

Tested on Ubuntu 11.04. The "totem" plugin seems to be involved.
Comment 1 Jesse Ruderman 2011-07-28 12:15:52 PDT
Created attachment 549191 [details]
output with stack traces
Comment 2 Josh Aas 2011-08-25 11:51:21 PDT
Fixed in the latest version of my patch.

Note You need to log in before you can comment on or make changes to this bug.