Last Comment Bug 675107 - Remove doctype specific code
: Remove doctype specific code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on: 675166
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 17:36 PDT by Jonas Sicking (:sicking) No longer reading bugmail consistently
Modified: 2011-09-18 09:43 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (10.99 KB, patch)
2011-07-28 17:36 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
no flags Details | Diff | Splinter Review

Description Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-07-28 17:36:12 PDT
Created attachment 549283 [details] [diff] [review]
Patch v1

Currently in both ReplaceOrInsertBefore and doInsertChildAt we have code that avoids implicitly adopting doctypes, instead the doctype node itself has a bunch of code in BindToTree to adjust its nodeinfo if it's being implicitly adopted.

This is pretty surprising and temporarily caused a regression in bug 648065.

It appears that the only reason we have all this is to allow us to make explicitly adopting doctypes *not* work (implicit does work though).

I talked with Anne and he removed this strange special case from DOM Core.

So here's a patch that simplifies this whole setup. It also removes some code to handle now-deprecated nodetypes from our adopt/import code.
Comment 1 Mozilla RelEng Bot 2011-07-29 01:00:22 PDT
Try run for d57917a61371 is complete.
Detailed breakdown of the results available here:
    http://tbpl.mozilla.org/?tree=Try&rev=d57917a61371
Results:
    success: 23
    warnings: 3
    failure: 1
Total buildrequests: 27
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sicking@mozilla.com-d57917a61371
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-08-26 20:19:40 PDT
Olli, would you mind taking this since it looked like you were looking at doctypes over in bug 675166.

The patch here works, but needs tests. The only tests it breaks are the ones from the W3C DOM test suite that checks for the old behavior. We should just nuke those and add tests that ensures that adopting/importing doctypes works as it should.
Comment 3 Olli Pettay [:smaug] 2011-08-27 05:06:37 PDT
I can look at this after bug 675166 is fixed (since I happened to write the patch for that first).
Comment 4 Olli Pettay [:smaug] 2011-08-27 06:15:52 PDT
And also because bug 675166 shouldn't cause any functional changes, but this bug does.
Comment 5 Olli Pettay [:smaug] 2011-09-18 09:42:47 PDT
Bug 675166 fixed also this one.

Note You need to log in before you can comment on or make changes to this bug.