Last Comment Bug 675309 - get rid of unnecessary calls to nsNPAPIPluginInstance::Start()
: get rid of unnecessary calls to nsNPAPIPluginInstance::Start()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Josh Aas
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 13:43 PDT by Josh Aas
Modified: 2011-08-02 10:53 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (2.29 KB, patch)
2011-07-29 13:43 PDT, Josh Aas
jst: review+
Details | Diff | Splinter Review

Description Josh Aas 2011-07-29 13:43:34 PDT
Created attachment 549458 [details] [diff] [review]
fix v1.0

nsNPAPIPluginInstance::Start is called in the [Try]SetUpPluginInstance code paths but we call it again if that succeeds. The second time it just bails at the start because the plugin is already started. There is one legitimate use case, or at least a case in which we can't simply remove the call, so that has been left.
Comment 1 Josh Aas 2011-08-02 10:53:24 PDT
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/f21f3fafab5b

Note You need to log in before you can comment on or make changes to this bug.