Position of abs pos element within floated rel pos containing block is incorrect. [ABS POS] [REL POS]

RESOLVED DUPLICATE of bug 210873

Status

()

Core
Layout
P4
normal
RESOLVED DUPLICATE of bug 210873
17 years ago
3 years ago

People

(Reporter: Val Sharp, Assigned: Marc Attinasi)

Tracking

({css2, testcase})

Trunk
mozilla1.2alpha
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P4] important abs pos bug)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2001012020

An Absolutely Positioned element with offsets specified, e.g. 'top' and/or 
'left', will not recognise a block which is both Relatively Positioned and 
Floated as its containing block. 

However, if the Absolutely positioned element has no offsets specified, i.e. 
auto, then it does use the relatively positioned floated block as its containing 
block.


Reproducible: Always
Steps to Reproduce:
The attached testcase illustrates both these situations:

Example 1 shows the Absolutely Positioned element with 'top:0px; left:0px' 
wrongly positioned outside the containing block.

Example 2 shows that the Absolutely Positioned element, with neither 'top' nor 
'left' specified, is properly contained within its containing block.

Examples 3 & 4 are the same as Examples 1 & 2, except the containing block is 
only Relatively Positioned, not Floated, showing that it's the use of Float in 
the containing block that causes the problem.


Expected Results:  The position of the absolutely positioned element should be 
calculated with respect to its containing block, even if that block is floated.
(Reporter)

Comment 1

17 years ago
Created attachment 24305 [details]
Floated containing block - testcase
Nice test case!!!
Assignee: pierre → attinasi
Status: UNCONFIRMED → NEW
Component: Style System → Layout
Ever confirmed: true
Keywords: css2, mozilla1.0, testcase
Summary: Position of Absolutely positioned element, within Relatively positioned Floated containing block, is incorrect. → Position of abs pos element within floated rel pos containing block is incorrect. [ABS POS] [REL POS]
Whiteboard: [Hixie-P4] important abs pos bug
(Assignee)

Comment 3

17 years ago
Accepting.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

17 years ago
Milestone set: Moz 1.0
Priority: -- → P4
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 5

16 years ago
*** Bug 93585 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 6

15 years ago
*** Bug 150181 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Not limited to Windows. OS->All.
OS: Windows 98 → All

Comment 8

15 years ago
Reconfirmed using FizzillaCFM/2002071208. Setting Platform=All.
Hardware: PC → All

*** This bug has been marked as a duplicate of 210873 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.