Better context menu for when rightclicking on images

VERIFIED DUPLICATE of bug 75338

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 75338
18 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: Brian Ryner (not reading))

Tracking

(Depends on: 1 bug)

Trunk
mozilla0.9.7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When you click on image on webpage you get the following context menu:
----------------------------
Back
Forward
Reload
Stop
-
View Page Source
View Image
Block Image from Loading
-
Bookmark this page
-
Save As...
Save Image...
--
Select All
Copy
Copy Image Location
--
Save As...

----------------------------

Why not change this into a more specific image context menu:
-----------------
View Image in new window
Block Image from Loading
--
Save Image...
Email Image...
Print Image...
--
Copy
Copy Image Location
--
Bookmark this Image
--------------------------------
Because sometimes it's impossible to click on a part of the page that's not an
image?  So the page context menu options should arguably still be in the image
context menu.

Comment 2

18 years ago
See also bug 26939, where mpt has attached a new spec for context menus.  
Unfortunately he keeps "back" and "forward" at the top of all context menus, 
making it hard to use context menus for "open link in new window" and "open 
frame in new window".

Comment 3

18 years ago
I'm operating under the assumption that context menus will eventually become a 
lot easier to open than they are now, so that choosing `Back' and `Forward' from 
the context menu will be considerably faster than going to the Back or Forward 
button in the toolbar. See bug 16766, bug 18726, bug 49844, and bug 36029.

But as shown in my spec, I agree that the other non-context-specific items --
`Reload', `Stop', `View Page Source', `Bookmark This Page', `Save As ...', and 
`Select All' -- should be removed.

Comment 4

18 years ago
I don't think the speed with which context menus appear affects which items 
should be at the top.  Only the first few items in a context menu can be used 
in a single gesture, and many users want to reserve that speed for commands 
that refer to a part of the page (link, image, frame) and therefore already 
require the use of a mouse for good speed.
Depending on where in the page one right-mouse-clicks, which constains the
context menu to appear with the cursor over some item other than the first, Back
and Forward won't necessarily be "be considerably faster than going to the Back
or Forward" toolbar buttons.  Ultimate speed in going back is achieved using a
keyboard shortcut, and forward isn't common enough in my opinion to justify much
concern, but it has a fine shortcut too.

Open (link|image|...) in new window, OTOH, has been first in context menus where
relevant for as long as I've worked on Navigator (since Netscape 1.1), IIRC. 
Someone correct me if my memory is wrong.  I use this feature a lot, and even
when the first item in the context menu can't be the one under the cursor
(because the link is too near the bottom of the page, e.g.), I know where to
"reach" to get this item.  It's the most frequently used item for me.  Why
should we move it down, for any reason?  Never mind to give Back and Forward
primacy that they don't merit, in my experience?

/be

Comment 6

18 years ago
Netscape 4.75 for Windows keeps back/forward/reload/stop at the top of the 
context menu for non-link images.  My guess for why NS4 works that way is that 
you can tell when your cursor is over a link ("hand" cursor) and can usually 
tell when you're in a frame, but you can't always tell when you're over an 
image.

Updated

17 years ago
Depends on: 75338

Comment 7

17 years ago
Jesse, you can't always tell when you're in a frame

Comment 8

17 years ago
When I right-click in one of the maps produced by Mapsonus or Mapquest, I don't
get the same menu you show here. I get:
  Open Frame in New Window
  Show Only This Frame
  Back
  Forward
  Reload Frame
  Stop
  View Page Source
  View Frame Source
  View Page Info
  View Frame Info
  Bookmark This Page
  Save As...
  Save Frame As...
  Select All
  Copy

View Image and Save Image are missing. Spurious View Frame and Frame Info are
included; I don't think there are any frames on the page. However, everything
works fine if I right-click in the Mozilla image at the top of this Bugzilla
page. Build 2001071604, Win2K.

Updated

17 years ago
Depends on: 103591
Context Menu cleanup/enhanced image features. 
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.7
Merry Christmas, Brian. 
Assignee: ben → bryner
Status: ASSIGNED → NEW
(Assignee)

Comment 11

17 years ago
Blake says he'd like to collapse this into one context menu bug.


*** This bug has been marked as a duplicate of 75338 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
vrfy dupr
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.