Last Comment Bug 675519 - build failed vc8/vc9 new-style jemalloc
: build failed vc8/vc9 new-style jemalloc
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla8
Assigned To: ABE Hiroki (:hATrayflood)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-31 13:34 PDT by ABE Hiroki (:hATrayflood)
Modified: 2011-08-10 08:57 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix vc8/9 new-style jemalloc build (1.53 KB, patch)
2011-07-31 13:37 PDT, ABE Hiroki (:hATrayflood)
khuey: review+
Details | Diff | Review

Description ABE Hiroki (:hATrayflood) 2011-07-31 13:34:31 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I tried vc8/vc9 build with new-style jemalloc. but it failed to build.


Actual results:

f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil.res finished
cp nssutil.def f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil.def
rm -f f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil3.dll
link -nologo -DLL -SUBSYSTEM:WINDOWS -DYNAMICBASE -MANIFEST:NO -LIBPATH:../../dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcrtd -NODEFAULTLIB:msvcprt -NODEFAULTLIB:msvcprtd -DEFAULTLIB:mozcrt -OUT:"libs" -OUT:"f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil3.dll" -DEF:f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil.def -MAP  f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\quickder.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secdig.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\derdec.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\derenc.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\dersubr.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\dertime.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\nssb64d.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\nssb64e.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\nssrwlk.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\nssilock.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\oidstring.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\portreg.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secalgid.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secasn1d.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secasn1e.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secasn1u.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secitem.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secload.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secoid.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\sectime.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\secport.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\templates.obj f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\utf8.obj   f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\dist\\lib\\plc4.lib f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\dist\\lib\\plds4.lib f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\dist\\lib\\nspr4.lib    f:\\mozilla\\nightly\\mozilla-central\\obj-i686-pc-mingw32\\nss\\nssutil\\nssutil.res
LINK : fatal error LNK1104: ファイル 'mozcrt.lib' を開くことができません。
make[7]: *** [f:/mozilla/nightly/mozilla-central/obj-i686-pc-mingw32/nss/nssutil/nssutil3.dll] Error 80
make[7]: Leaving directory `/f/mozilla/nightly/mozilla-central/security/nss/lib/util'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/f/mozilla/nightly/mozilla-central/security/nss/lib'
make[5]: *** [libs] Error 2
Comment 1 ABE Hiroki (:hATrayflood) 2011-07-31 13:37:51 PDT
Created attachment 549687 [details] [diff] [review]
fix vc8/9 new-style jemalloc build
Comment 2 ABE Hiroki (:hATrayflood) 2011-07-31 13:43:53 PDT
"-LIBPATH:../../dist/lib" is DLLFLAGS at autoconf.mk:645. It is unnecessary, but set.
To unset DLLFLAGS, clear WIN32_CRT_SRC_DIR when new-style jemalloc.
Comment 3 ABE Hiroki (:hATrayflood) 2011-07-31 13:48:59 PDT
build successful, but firefox.exe and xpcshell.exe crashes MSVCR80/90.dll configuration.
It caused by "-MANIFEST:NO". so remove from MOZ_MEMORY_LDFLAGS at configure.in:7554.
Comment 4 ABE Hiroki (:hATrayflood) 2011-07-31 13:56:01 PDT
(In reply to comment #2)
> "-LIBPATH:../../dist/lib" is DLLFLAGS at autoconf.mk:645. It is unnecessary,
> but set.
> To unset DLLFLAGS, clear WIN32_CRT_SRC_DIR when new-style jemalloc.

sorry. "-LIBPATH:../../dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcrtd -NODEFAULTLIB:msvcprt -NODEFAULTLIB:msvcprtd -DEFAULTLIB:mozcrt" is DLLFLAGS at autoconf.mk:645. It is unnecessary, but set.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-01 10:01:52 PDT
Comment on attachment 549687 [details] [diff] [review]
fix vc8/9 new-style jemalloc build

r=me

Thanks for this!
Comment 7 Mounir Lamouri (:mounir) 2011-08-09 05:52:40 PDT
Backed-out from inbound due to a perma-orange, see:
http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642

The patch in this bug might not bee related, the entire push has been backed out.
Comment 8 Justin Wood (:Callek) 2011-08-10 00:45:05 PDT
(In reply to Justin Wood (:Callek) from comment #6)
> http://hg.mozilla.org/integration/mozilla-inbound/rev/7b8bab56ab93

(In reply to Mounir Lamouri (:volkmar) from comment #7)
> Backed-out from inbound due to a perma-orange, see:
> http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
> 
> The patch in this bug might not bee related, the entire push has been backed
> out.

Relanded as: http://hg.mozilla.org/integration/mozilla-inbound/rev/85e0a8801a46
Comment 9 :Ehsan Akhgari (out sick) 2011-08-10 08:57:35 PDT
http://hg.mozilla.org/mozilla-central/rev/85e0a8801a46

Note You need to log in before you can comment on or make changes to this bug.