Stalled (unloaded) tabs should be styled to be visually distinguishable

RESOLVED DUPLICATE of bug 716279

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 716279
7 years ago
6 years ago

People

(Reporter: Joe Wilson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Since bug 586068 landed - there is a new state for every tab: it can be stalled (unloaded).

But on the tab bar they look absolutely similar to the loaded tabs.
In some cases a user might want to know whether the page is loaded or not. An example case may be a heavy (with lots of graphics) page that a user wanted to read later, when he has more free time to read the huge text on that page.
After the restart of the browser, all the tabs gets stalled, as user has browser.sessionstore.max_concurrent_tabs = 0 as he feels more comfortable this way.
Some other tabs may have been also postponed by the user in order to read them later, but now all he sees is tabs' titles, and he doesn't remember anymore whether this tab is that awfully heavy page, that he doesn't want to read now, or it is one of those small scientific articles he wanted to read later, when he was busy, but is willing to read now.
(Reporter)

Updated

7 years ago
Depends on: 586068
Duplicate of this bug: 696126
For showing unloaded state faded tabs (like BarTab has) may be used.
In addition, the List all tabs popup and Panorama may also indicate unloaded tabs.

Comment 3

7 years ago
This issue does reproduce, but it seems to be more an enhancement request than an actual bug.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm duping this forward because there's a bit more discussion in the other bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 716279

Comment 6

6 years ago
Please, change the status of this bug back to "new" and mark the new one as duplicate, this will be more correct.
(In reply to Sean Newman from comment #6)
> Please, change the status of this bug back to "new" and mark the new one as
> duplicate, this will be more correct.

The other bug has more value as the active bug, so I will leave it as is.

Comment 8

6 years ago
How can a duplicate have more value? These bugs are equal, except this one is older and the new is a dupe of this one.
(In reply to Sean Newman from comment #8)
> How can a duplicate have more value? These bugs are equal, except this one
> is older and the new is a dupe of this one.

There is discussion amongst parties involved in making it happen in the other bug. If we decided which bug was a duplicate purely on age, many important discussions would be missed. Let's not get hung up on that and just move on.
Sean: please do not bulk-CC people on bugs without good reason. Thanks.
You need to log in before you can comment on or make changes to this bug.