Sound playing, Flash and Javascript

RESOLVED DUPLICATE of bug 24418

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 24418
6 years ago
6 years ago

People

(Reporter: Dhaivat, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.122 Safari/534.30

Steps to reproduce:

Had several tabs open.


Actual results:

Sound started playing.


Expected results:

I should be able to find the source of the sound.

What I'm saying is, we should add a feature, that preferably figures out if flash is playing sound on a page, and notify the user about audio tags on a page that are currently playing (this may involve some javascript trickery on the side of the website, so the code must be very careful). I'm pretty sure that we cannot do the former, as flash is a closed source plugin, but, the latter would not be difficult if we ignored javascript, and would be a real task if we considered the effects of javascript on tags (which would be far more useful). 

Sort of like http://i.imgur.com/PIJRn.png.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 24418
(Reporter)

Comment 2

6 years ago
Not quite, I'm just saying to add an icon, not disable anything. I looked at that bug.
You need to log in before you can comment on or make changes to this bug.