Last Comment Bug 675630 - Crash [@ nsBuiltinDecoderReader::VideoQueueMemoryFunctor::operator()]
: Crash [@ nsBuiltinDecoderReader::VideoQueueMemoryFunctor::operator()]
Status: RESOLVED FIXED
[inbound]
: crash, regression
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 All
: -- critical (vote)
: mozilla8
Assigned To: Matthew Gregan [:kinetik]
:
Mentors:
Depends on:
Blocks: 672755
  Show dependency treegraph
 
Reported: 2011-08-01 08:20 PDT by Jesse Ruderman
Modified: 2011-09-01 09:09 PDT (History)
8 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack trace (8.47 KB, text/plain)
2011-08-01 08:20 PDT, Jesse Ruderman
no flags Details
patch v0 (1.11 KB, patch)
2011-08-01 20:24 PDT, Matthew Gregan [:kinetik]
cpearce: review+
Details | Diff | Review

Description Jesse Ruderman 2011-08-01 08:20:39 PDT
Created attachment 549806 [details]
stack trace

1. Load http://www.thewildernessdowntown.com
2. Load about:memory in another tab

Result: Crash [@ nsBuiltinDecoderReader::VideoQueueMemoryFunctor::operator()]

bp-22749078-5014-4298-aa40-13de32110801
Comment 1 Timothy Nikkel (:tnikkel) 2011-08-01 09:44:50 PDT
This crash seems to be pretty easy for me to trigger on Linux with just loading about:memory in my normal session.
Comment 2 XtC4UaLL [:xtc4uall] 2011-08-01 14:29:49 PDT
bp-818ac8d6-8442-4aaa-9721-af9b52110801 Windows XP Crash Version.
Comment 3 Matthew Gregan [:kinetik] 2011-08-01 20:24:47 PDT
Created attachment 550006 [details] [diff] [review]
patch v0

Add a missing null check for frames without an image, such as frames created via VideoData::CreateDuplicate.
Comment 4 Marco Bonardo [::mak] 2011-08-02 03:45:18 PDT
http://hg.mozilla.org/mozilla-central/rev/b3a481c2e02a

Note You need to log in before you can comment on or make changes to this bug.