Firefox crashes while on a page that uses WebGL [@ gl::VertexDataConverter<float, gl::WidenRule<int, 2>, gl::ConversionRule<int, 0, int>, gl::DefaultVertexValues<float, int> >::convertArray(void const*, unsigned int, unsigned int, void*) ]

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: alindeac, Unassigned)

Tracking

({crash, regression})

6 Branch
mozilla8
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(firefox5 unaffected, firefox6+ fixed, firefox7+ fixed)

Details

(Whiteboard: [6b4], [6b5], crash signature)

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

Firefox 6.0b4 crashes sometimes when multiple pages that uses WebGL are loaded in the same window.

Reproducible: Sometimes

Steps to reproduce:

1. Load http://www.ibiblio.org/e-notes/webgl/waves/wave.html
2. In a second tab load http://bodybrowser.googlelabs.com/body.html#m=0&note=&ui=1&opa=s:1,m:1,sk:1,c:1,o:1,ci:1,l:1,n:1&nav=-73.81,104.98,250&sel=p:;h:;s:;c:0;o:0 
3. Start playing with the model from step 2 in the left panel of the page (maximize it, spin it, change body layers.

Actual results:

Firefox crashes. These are the crash reports:
bp-38cae2ad-2b84-445a-bee5-85bb12110801
bp-62986bef-f1d0-4d1b-b8a3-229122110801
bp-7c5b81dc-c39c-47d9-a6fb-e71c92110801
bp-ecb6fdf8-71a7-4253-b58b-b28f22110801
bp-09024ea2-a05a-46ec-bfb6-33e872110801
bp-79049038-aebb-4baa-8e45-cf1fa2110801
bp-7ea356f5-9c27-4310-bac5-814d92110801

Expected results:

Firefox works without crashing.
Summary: Firefox crashes wile on a page that uses WebGL → Firefox crashes while on a page that uses WebGL
Whiteboard: [6b4]

Updated

6 years ago
Summary: Firefox crashes while on a page that uses WebGL → Firefox crashes while on a page that uses WebGL [@ gl::VertexDataConverter<float, gl::WidenRule<int, 2>, gl::ConversionRule<int, 0, int>, gl::DefaultVertexValues<float, int> >::convertArray(void const*, unsigned int, unsigned int, void*) ]
The signature is very reminiscent of bug 646825. But if it were a duplicate, it would be fixed in Firefox 6.
Severity: normal → critical
Keywords: crash
This is ANGLE bug 139:
http://code.google.com/p/angleproject/issues/detail?id=139

ANGLE r712 (and perhaps 713) should fix it.

Comment 3

6 years ago
We want to take this in Firefox 6.
Created attachment 550184 [details] [diff] [review]
ANGLE r712

This is ANGLE r712, r=upstream.
Attachment #550184 - Flags: review+
Attachment #550184 - Flags: approval-mozilla-beta?
Attachment #550184 - Flags: approval-mozilla-aurora?

Comment 5

6 years ago
Comment on attachment 550184 [details] [diff] [review]
ANGLE r712

Approved for releases/mozilla-aurora and mozilla-beta. Please land asap
Attachment #550184 - Flags: approval-mozilla-beta?
Attachment #550184 - Flags: approval-mozilla-beta+
Attachment #550184 - Flags: approval-mozilla-aurora?
Attachment #550184 - Flags: approval-mozilla-aurora+
Landed on central, aurora, beta.

http://hg.mozilla.org/mozilla-central/rev/d6301744afa9
http://hg.mozilla.org/releases/mozilla-aurora/rev/e442db72f342
http://hg.mozilla.org/releases/mozilla-beta/rev/99e2010c484c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox5: --- → unaffected
status-firefox6: --- → fixed
status-firefox7: --- → fixed
tracking-firefox6: --- → +
tracking-firefox7: --- → +
Target Milestone: --- → mozilla8
Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

I got another crash on Firefox 6 beta 5 after unlocking my computer.

STR:
1. I loaded the two pages from the description.
2. I locked my computer for about 10 min.

After unlock Firefox crashed, this is the crash report:
bp-ea07038b-3897-40f5-8943-2613c2110805

I just got another crash while writing this Comment, the crash report is:
bp-327a6f6b-8200-4543-ac8f-fa82c2110805
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Oops. Trying to reproduce now.

Updated

6 years ago
Whiteboard: [6b4] → [6b4], [6b5]

Updated

6 years ago
status-firefox6: fixed → affected
status-firefox7: fixed → affected
If this is the issue r712 is patching then it's a regression from bug 646825 (both patches from angle bug 139). If r712 doesn't fix this crash then it's something else entirely.
Results from trying to reproduce:
 * on Win7, I can't reproduce any crash
 * on WinXP, I could reproduce one crash with these STR, but it was a different one altogether: bug 676918

Comment 11

6 years ago
So, sounds like we are ok here for Fx6. Adding the screen locking into the steps to reproduce makes this a lot less common (looks like 3 total crashes across all versions over the last week).

Comment 12

6 years ago
I see ANGLE r686 in about:support for 6.0b5/20110804030150.
Is something missing in the ANGLE r712 patch?
We're at ANGLE r686, plus some patches including r702 and r712, but we don't have all the ANGLE revisions in between, so I'd still call this 'ANGLE r686 plus patches'.

The README.Mozilla file is indeed outdated, it says r653, should say r686.
Setting status-firefox6 and status-firefox7 to reflect the aurora and beta checkins in comment 6 (otherwise this bug appears on the "approved but not landed" triage list).
status-firefox6: affected → fixed
status-firefox7: affected → fixed

Updated

6 years ago
Crash Signature: [@ gl::VertexDataConverter<float, gl::WidenRule<int, 2>, gl::ConversionRule<int, 0, int>, gl::DefaultVertexValues<float, int> >::convertArray(void const*, unsigned int, unsigned int, void*) ]
This appears to have been fixed. Please reopen if you're still hitting this crash.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.