Last Comment Bug 675645 - Firefox freezes when using Pop out while in Fullscreen mode on Youtube
: Firefox freezes when using Pop out while in Fullscreen mode on Youtube
Status: RESOLVED INVALID
[7rc]
: hang, regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows XP
: P3 critical with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 701739 (view as bug list)
Depends on:
Blocks: 648935
  Show dependency treegraph
 
Reported: 2011-08-01 09:28 PDT by Simona B [:simonab]
Modified: 2014-10-28 07:16 PDT (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
affected
-
wontfix


Attachments
WinDbg log (88.89 KB, text/plain)
2011-08-01 10:01 PDT, Alice0775 White
no flags Details

Description Simona B [:simonab] 2011-08-01 09:28:09 PDT
Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

Firefox freezes when trying to switch from Youtube Fullscreen to Pop out mode. This is reproducible whether Hardware acceleration in On or Off on Win XP and Win 7 x86

Reproducible: always

Steps to reproduce:
 1. Go to Youtube
 2. Select any video
 3. Go into Fullscreen mode
 4. Right click and choose Pop out from the context menu

Actual results:
 - Firefox freezes and has to be closed by killing the process

Expected results:
 - Pop out window is displayed 


Note: 
 - issue is not reproducible on Fx 5
Comment 1 Alice0775 White 2011-08-01 09:50:43 PDT
Regression window(m-c hourly)
Works;
http://hg.mozilla.org/mozilla-central/rev/4aad8ef5c011
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110518 Firefox/6.0a1 ID:20110518024646
Fails:
http://hg.mozilla.org/mozilla-central/rev/d40eac0106f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110518 Firefox/6.0a1 ID:20110518050124
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4aad8ef5c011&tochange=d40eac0106f5

Triggered by:
Bug 648935 - Firefox freezes when an alert box generated by Flash is shown
Comment 2 Alice0775 White 2011-08-01 10:01:33 PDT
Created attachment 549836 [details]
WinDbg log
Comment 3 Jim Mathies [:jimm] 2011-08-01 10:04:00 PDT
stack:

http://pastebin.mozilla.org/1286715
Comment 4 George Carstoiu 2011-08-01 10:14:35 PDT
Regression range:

Last good nightly: 2011-05-18
First bad nightly: 2011-05-19

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dec16a247230&tochange=caba046161e5
Comment 5 christian 2011-08-02 09:24:17 PDT
Jim, any update on this? We'd like to get a fix in today if at all possible. Alternatively, if you could identify the change that caused it we might just want to backout for 6 and fix correctly for 7+
Comment 6 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-08-02 11:48:10 PDT
This is most likely bug 648935.
Comment 7 Jim Mathies [:jimm] 2011-08-02 11:56:01 PDT
(In reply to comment #5)
> Jim, any update on this? We'd like to get a fix in today if at all possible.
> Alternatively, if you could identify the change that caused it we might just
> want to backout for 6 and fix correctly for 7+

No we don't want to do that. The bug the original patch fixed is far more severe. This is a corner case, I seriously doubt a lot of people right-click on youtube videos to select the "popout" option from fullscreen.
Comment 8 Jim Mathies [:jimm] 2011-08-02 12:40:14 PDT
This is a real PITA unfortunately. What's happening here - 

1) flash calls eval on the parent with some script that creates a popup
2) parent evals the script, starts creating a new window
3) parent detect ui, sends ProcessRemoteNativeEventsInRPCCall to child
4) child spins spin loop
5) child receives a windowing event
5) child calls getvalue on parent
*deadlock*

child is in it's second stack frame, so no spin loop is running, and the parent is still in a synchronous call trying to create the popup.
Comment 9 Jim Mathies [:jimm] 2011-08-02 12:44:38 PDT
Hmm, I wonder why this isn't working, the child sets 

mTopFrame->mSpinNestedEvents = true;

for the top frame, that should have triggered a new spin loop.
Comment 10 Jim Mathies [:jimm] 2011-08-02 12:50:02 PDT
(In reply to comment #9)
> Hmm, I wonder why this isn't working, the child sets 
> 
> mTopFrame->mSpinNestedEvents = true;
> 
> for the top frame, that should have triggered a new spin loop.

Ok, so yes, the getvalue call is on a new frame. Hence the deadlock. The 'top frame' spinning the loop is below it.
Comment 11 Jim Mathies [:jimm] 2011-08-02 13:59:49 PDT
Notes for driver: 

There doesn't appear to be an easy fix for this, I'll keep looking though.

Bug 648935 introduced new code that dealt with a parent side hang when plugins call evaluate on the parent and the script generates a popup or alert box. 

This bug's particular hang is a side effect of that patch where the child is allowed to processes Windowing messages that then trigger calls to the browser while the browser is busy make sync calls to Windows.

Both hangs are parent side, so I don't believe either can be correlated with crash stat data.

My intuition is that this hang is less of an issue, but I have no data other than the perceived commonality of the STR, and the amount of bug traffic I've seen to base that opinion on.

I can disable the code in bug 648935 with a single commented line, so if we want to play it safe, accept that flash alert hangs will hang the browser, we can do that.
Comment 12 christian 2011-08-03 14:53:18 PDT
I think if that's the tradeoff we'll live with this bug living in 6. We'll keep tracking it to see if this is more common than thought.
Comment 13 AndreiD[QA] 2011-09-23 00:50:31 PDT
The issue, as it was reported, with the steps to reproduce in the description is still visible on Firefox 7 Release Candidate. Changing the keyword to 7rc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

Also, this is visible on Nightly:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110921 Firefox/9.0a1
Comment 14 Vlad [QA] 2011-09-23 06:49:08 PDT
I tried to reproduce this on 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0 
and I got no crash, instead, when I choose "poop out" the whole screen turns black (still in full screen) and the video in the pop-up plays in the background.
Comment 15 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-26 10:33:03 PDT
Just adding to comment 14...

Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0 ID:20110922153450
1) Go to Youtube
2) Play a video
3) Click FULLSCREEN
4) Right click and select "Pop Out"
5) Press ESC key

Result:
After step 4, the video stops at the current frame but the audio continues
After step 5, the video and audio restart from the beginning in a pop-out window

Nominating for Firefox 8 -- can we get this fixed soon?
Comment 16 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-09-26 10:45:12 PDT
See comment 7 and further.
Thus far, there is no fix found that doesn't regress bug 648935.
Comment 17 christian 2011-10-25 20:56:01 PDT
---------------------------------[ Triage Comment ]---------------------------------

We are not tracking this for Firefox 8. It was a regression caused by Firefox 6 with reproduction steps that generally don't happen in the wild (and once a user does it they will not do so again).

It was previously decided to ship with and relnote this regression and that decision still stands, as the benefits of the regressing bug (bug 648935) outweigh this new issue.

When a fix is found for this we will of course look to take it.
Comment 18 Sumanto Chakraborty 2011-12-21 19:04:23 PST
I have tested this on 9.0 ans it still persists. While playing around with the problem, I found disabling Pop-blocker resolves the problem.It looks like a pop-blocker behavior to me.
Thankx.
Comment 19 rockhopper_everyonefan 2012-01-10 00:42:54 PST
I tried this before. It did hang, but when I opened Windows Task Manager, there were signs of 2 of the Youtube Pop-out video and the Youtube non-pop-out video. Is that something to do?
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-10 15:29:39 PST
@Sumanto, is the "Pop-blocker" you refer to an add-on?

@Rockhooper, can you provide a screenshot of what you see? I'm not sure I understand.
Comment 21 Sumanto Chakraborty 2012-01-10 15:52:19 PST
I was referring to 'Block pop-up window' under content tab in the option menus.
Thankx.
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-10 17:04:22 PST
Simona, can you confirm Sumanto's workaround works for you?
Comment 23 Simona B [:simonab] 2012-01-11 09:10:53 PST
Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20120111 Firefox/12.0a1

Firefox is still freezing on my machine after disabling 'Block pop-up window'.
Comment 24 Jim Mathies [:jimm] 2012-01-11 13:45:20 PST
*** Bug 701739 has been marked as a duplicate of this bug. ***
Comment 25 rockhopper_everyonefan 2012-01-18 03:59:23 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #20)
> @Sumanto, is the "Pop-blocker" you refer to an add-on?

@Rockhooper, can you
> provide a screenshot of what you see? I'm not sure I understand.

Check my website. Special directions available there.

www.superbloggies.webs.com
Comment 26 rockhopper_everyonefan 2012-01-18 04:12:44 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #20)
> @Sumanto, is the "Pop-blocker" you refer to an add-on?

@Rockhooper, can you
> provide a screenshot of what you see? I'm not sure I understand.

Go to my webpage to view the error.

www.superbloggies.webs.com
Comment 27 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-20 11:43:51 PST
(In reply to rockhopper_everyonefan from comment #26)
> Go to my webpage to view the error.
> www.superbloggies.webs.com

Next time, please attach the screenshot to this bug; this way we can see it if your website goes down.

What you are seeing is duplicate processes, not sure if this is the same bug. I will defer to Jim on this point.
Comment 28 Paul Silaghi, QA [:pauly] 2012-06-07 23:13:19 PDT
Still an issue on FF 14b6: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0
Comment 29 Alice0775 White 2012-06-07 23:26:04 PDT
FYI
dom.ipc.plugins.enabled = false helps
Comment 30 Paul Silaghi, QA [:pauly] 2012-06-07 23:35:30 PDT
Indeed, everything's ok with dom.ipc.plugins.enabled = false. Thanks Alice!
Comment 31 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-08 10:17:30 PDT
So this is probably a regression caused by IPC Plugins. Can we get a developer to investigate this further?
Comment 32 Simona B [:simonab] 2013-05-28 06:05:34 PDT
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130525 Firefox/24.0

I can still reproduce this on the latest Nightly.

Why was this bug marked as Resolved Incomplete?
Comment 33 Jim Mathies [:jimm] 2013-05-28 06:23:29 PDT
Shouldn't have been, this is a left over bug from oopp work.
Comment 34 Jim Mathies [:jimm] 2014-10-28 07:16:57 PDT
Working on bug 669200 I came back to this to see if that worked helped. Unfortunately it looks like youtube removed the popout option from the context menu. If anyone can find a flash video with this option, please reopen.

Note You need to log in before you can comment on or make changes to this bug.