The default bug view has changed. See this FAQ.

Inputking.com stops loading

VERIFIED FIXED in Firefox 8

Status

()

Core
JavaScript Engine
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Kemcy BEST, Assigned: evilpie)

Tracking

({regression})

8 Branch
mozilla8
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox8+ fixed)

Details

(Whiteboard: [inbound])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110727 Firefox/8.0a1
Build ID: 20110727114959

Steps to reproduce:

I used inputking.com to type Chinese on Linux computer (where I do not have admin rights to install input methods). The PC runs Ubuntu 10.04 LTS. I'm testing the nightly builds.


Actual results:

On a recent update of 8.0a1, I found inputking.com fails to load.

STR:
1. Open http://inputking.com/
2. Check "Chinese (中文)" on the top and click the yellow button "Start Inputking" at the bottom.
3. A new window or tab should open.

Problem: this window (or tab) displays Please wait... forever.


Expected results:

This window (or tab) should finish loading and display an input field to type text.

works in
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux/1311743874/

breaks in
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux/1311792599/

Comment 1

6 years ago
Confirmed on 
http://hg.mozilla.org/mozilla-central/rev/f92e021f1f44
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110801 Firefox/8.0a1 ID:20110801030916

Pushlog in m-i
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0d37af9e506f&tochange=a774533fbbf1


In local build( from m-i repro.)
build from a774533fbbf1 : displays Please wait... forever
build from 54b8ca3b0c7a : displays Please wait... forever
build from 0d37af9e506f : display an input field to type text

triggered by:
54b8ca3b0c7a	Tom Schuster — Bug 652771 - Update Unicode character support for space categorization, also somewhat for uppercase and lowercase (although these will only be fully fixed in followup bugs). r=jwalden. Further (lumped together to address interdependencies): Bug 672760 - Don't pass the EOF non-character to any of the Unicode character-categorization functions. r=jwalden
Assignee: nobody → general
Blocks: 652771
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: general → general

Comment 2

6 years ago
An Error shown in Error Console as follows

Error: missing ( before formal parameters
Source File: http://inputking.com/ime/ime_new.php
Line: 4, Column: 2256
Source Code:
code_holder='';cancel_key_event=false;$('#edit_area').ke............
(Assignee)

Comment 3

6 years ago
Reduced testcase:
function key_down_英() {
}
The problem is that make_unicode does not parse "CJK Ideograph" eg.
4E00;<CJK Ideograph, First>;Lo;0;L;;;;;N;;;;;
9FCB;<CJK Ideograph, Last>;Lo;0;L;;;;;N;;;;;
Which U+82F1 (英) is part of, and these are apparently even valid identifiers, because they have the class (Lo).
Requesting tracking for this regression.
tracking-firefox8: --- → ?
(Assignee)

Comment 5

6 years ago
Created attachment 550090 [details] [diff] [review]
v0

So after tracking this down, the fix is really easy, we just need to use the right flags for all characters in this code range. I built with this and it fixed this bug and bug 675400.

I really need to abstract make_unicode.py a lot better, i am going to to this bug 672042 otherwise the code will get even more hostile.
Attachment #550090 - Flags: review?(jeff.walden)
tracking-firefox8: ? → +
(Assignee)

Comment 6

6 years ago
Created attachment 550152 [details] [diff] [review]
v1 - the fix
(Assignee)

Comment 7

6 years ago
Created attachment 550153 [details] [diff] [review]
add UnicodeData
Attachment #550153 - Flags: review?(jwalden+bmo)
(Assignee)

Updated

6 years ago
Attachment #550152 - Flags: review?(jwalden+bmo)
(Assignee)

Updated

6 years ago
Attachment #550090 - Attachment is obsolete: true
Attachment #550090 - Flags: review?(jeff.walden)
(Assignee)

Updated

6 years ago
Assignee: general → evilpies
Comment on attachment 550152 [details] [diff] [review]
v1 - the fix

Review of attachment 550152 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/tests/ecma_5/misc/unicode-identifier-1d17.js
@@ +15,5 @@
>  
>  var o = {}
>  try {
>      eval('o.\\u1D17 = 42');
> +    eval('o.\\u82F1 = "hello world"');

Pedantically, these changes probably want to be in a new test file, but I don't think it really matters that much.
Attachment #550152 - Flags: review?(jwalden+bmo) → review+
Attachment #550153 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 9

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/9ef8e264cd41
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/9ef8e264cd41
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
Blocks: 675400
(Assignee)

Updated

6 years ago
Duplicate of this bug: 675400
(Reporter)

Comment 12

6 years ago
Thanks! Verified.
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-firefox8: --- → fixed
You need to log in before you can comment on or make changes to this bug.