Closed Bug 675899 Opened 9 years ago Closed 8 years ago

HTML5 video player should show controls when video ends (if controls attribute is present)

Categories

(Toolkit :: Video/Audio Controls, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
mozilla10

People

(Reporter: glibnes, Assigned: padenot)

Details

Attachments

(1 file)

Currently, when Video in WebM format ends, there is no "notification" that it has ended. It would be great, if for example video screen on end become covered by black transparent frame (like when the video is loading).
Severity: normal → enhancement
Component: General → Video/Audio Controls
Product: Firefox → Toolkit
QA Contact: general → video.audio
Version: 7 Branch → Trunk
It could offer to play the video again....
We should probably, at a minimum, redisplay the controls. Then you can see that (1) something happened and (2) it's at the end.

YouTube et al show extra stuff at the end, but we obviously don't have anything similar. I suppose we could show like a big "rewind" icon or something, but maybe just showing the controls is enough?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Assignee: nobody → paul
Here is a patch that simply show the controls when a video ends.
Attachment #551075 - Flags: review?(dolske)
Status: NEW → ASSIGNED
Comment on attachment 551075 [details] [diff] [review]
Patch v0 -- Show controls when a video ends.

r+ with leaving the call to setupStatusFader() (just add the startFadeIn() call)... I _think_ there can be cases where setupStatusFader() here would be removing a throbber overlay... It should be harmless in any case.
Attachment #551075 - Flags: review?(dolske) → review+
Summary: WebM Player should do something with screen when Video ends → HTML5 video player should show controls when video ends
Summary: HTML5 video player should show controls when video ends → HTML5 video player should show controls when video ends (if controls attribute is present)
Addressed review comments. Pushed to fx-team:
https://hg.mozilla.org/integration/fx-team/rev/0c3d5e7ce23c
Keywords: uiwanted
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0c3d5e7ce23c
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla10
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0

Verified the fix on the above builds: the controls bar is displayed when video ends if controls are enabled, but if controls are hidden, there is no "notification" that the video finished (nothing happens; controls are not displayed). Also, if video is played in full screen, it automatically exits full screen when it finishes playing. Is this intended?
(In reply to Mihaela Velimiroviciu [QA] from comment #7)
> Also, if video is played in full screen, it automatically exits
> full screen when it finishes playing. Is this intended?

Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0 beta 6
Mozilla/5.0 (Windows NT 6.1; rv:11.0a2) Gecko/20120125 Firefox/11.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a2) Gecko/20120125 Firefox/11.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0

Verified again with the latest beta (10beta 6) and Aurora and I could not reproduce this. 
Marking as VERIIFED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.