Last Comment Bug 675945 - about:permissions auto-shows basic auth login for saved site
: about:permissions auto-shows basic auth login for saved site
Status: RESOLVED FIXED
[Fixed by 670341]
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 670341
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 08:15 PDT by Stephen Sagers
Modified: 2011-08-05 08:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
FF_about_permissions.jpg (93.61 KB, image/jpeg)
2011-08-02 08:15 PDT, Stephen Sagers
no flags Details

Description Stephen Sagers 2011-08-02 08:15:33 PDT
Created attachment 550081 [details]
FF_about_permissions.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110802 Firefox/7.0a2
Build ID: 20110802042011

Steps to reproduce:

Typed about:permissions into url.


Actual results:

When permissions page loaded (no specific site selected), it popped up a basic authentication for a site I had saved basic auth credentials.


Expected results:

Basic Auth popup should not appear.
Comment 1 Stephen Sagers 2011-08-02 08:25:11 PDT
Also, when I have 'All Sites' selected and search in the Saved Passwords box for the site that has the saved basic auth credentials it shows up.  But when I find the site in the about:permissions box, it says '0 passwords are saved for this website'.
Comment 2 (mostly gone) XtC4UaLL [:xtc4uall] 2011-08-02 09:16:18 PDT
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110802 Firefox/8.0a1 ID:20110802025715.

Maybe Basic Auth Prompts should be suppressed (no Usage?) when about:permissions is loaded?
Comment 3 :Margaret Leibovic 2011-08-02 10:02:00 PDT
I believe this is caused by bug 670341, which is more of a problem with the favicon service API.
Comment 4 :Margaret Leibovic 2011-08-04 09:06:25 PDT
The fix for bug 670341 was just pushed to mozilla-central. Could you try out the latest Nightly build tomorrow and see if this problem still exists?
Comment 5 Stephen Sagers 2011-08-04 09:08:15 PDT
I certainly will.  I will let you know tomorrow if it works.
Comment 6 (mostly gone) XtC4UaLL [:xtc4uall] 2011-08-04 10:44:54 PDT
(In reply to comment #4)
For me it's fixed. Tested against Tinderbox Build http://hg.mozilla.org/mozilla-central/rev/c7ea065539d2 what contains the Fix for Bug 670341.
Comment 7 Stephen Sagers 2011-08-05 08:01:50 PDT
I've confirmed that nightly no longer brings up the basic auth window when opening about:permissions.

On a somewhat related note - I am still seeing the issue from Comment #1.  Should I open a separate ticket for that?  Thanks.
Comment 8 (mostly gone) XtC4UaLL [:xtc4uall] 2011-08-05 08:24:14 PDT
(In reply to Stephen Sagers from comment #7)
Yes, please file a new Report.

Note You need to log in before you can comment on or make changes to this bug.