[10.7] Support new MagicMouse back/forward gestures in OSX Lion

RESOLVED DUPLICATE of bug 668953

Status

()

RESOLVED DUPLICATE of bug 668953
7 years ago
3 years ago

People

(Reporter: emanuele.alimonda, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 550287 [details]
One Finger Swipe in Lion (System Preferences animation)

Equivalent to bug #668953, but specific to the MagicMouse rather than MacBook trackpad / MagicTrackpad.

OS X Lion adds new gestures for the Back and Forward actions, and the default ones for the MagicMouse are one-finger swipes.

On OS X Snow Leopard, the Back / Forward actions were two-finger swipes, which are now used to switch to other Desktops in Mission Control.

Steps to reproduce:
1. Visit several pages on the same tab, to build a "Forward/Back" history (i.e. the Back and Forward buttons become active)
2. If the current page has horizontal scrollbars, scroll all the way to the left.
3. Keep scrolling left.
4. If the current page has horizontal scrollbars, scroll all the way to the right.
5. Keep scrolling right.

Expected output:
At step 3, the scroll gesture should trigger a "Back" event, as it happens in other programs, including Safari.
At step 5, the scroll gesture should trigger a "Forward" event, as it happens in other programs, including Safari.

Actual output:
At step 3 and 5 nothing happens.  Furthermore, by trying to use the Snow Leopard gesture (two-finger swipe) to achieve the same result, the user gets moved to the previous/next virtual Desktop.

In attachment, a video from the animation shown in the Mouse System Preferences for the above mentioned gesture.  Please keep in mind that the video is taken on a Mac with Reverse scrolling enabled, rather than the default Natural scrolling.
(Reporter)

Updated

7 years ago
Attachment #550287 - Attachment mime type: application/octet-stream → video/webm

Updated

7 years ago
Blocks: 636455

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for the detailed bug report Emanuele.

This bug is similar to bug 668953.
Depends on: 668953
(Reporter)

Comment 2

7 years ago
This should now be fixed as bug #668953 is fixed.  The latest try build for that bug also seems to work properly with MagicMouse gestures.

Comment 3

7 years ago
I can confirm that this works with a Magic Mouse. However, I've found myself wanting to disable this since I keep activating it unintentionally. Unfortunately it seems it does not respect the "Swipe between pages" setting in System Preferences. Is it supposed to?
> Unfortunately it seems it does not respect the "Swipe between pages"
> setting in System Preferences.

Please explain what you mean more precisely. 

And does this problem (whatever it is) also effect using the
two-finger horizontal gesture to swipe between pages?

For what it's worth, I find that turning off "Swipe between pages"
under "Trackpad" (in system preferences) does stop two-finger
horizontal swiping from working.
In other words, is there more than one "Swipe between pages" setting in system preferences (one under Trackpad and one elsewhere)?

I'm unable to test with a Magic Mouse, since I don't yet own one.
(Reporter)

Comment 6

7 years ago
(In reply to Magne Andersson from comment #3)
> I can confirm that this works with a Magic Mouse. However, I've found myself
> wanting to disable this since I keep activating it unintentionally.
> Unfortunately it seems it does not respect the "Swipe between pages" setting
> in System Preferences. Is it supposed to?

Works for me with today's nightly (Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0a1) Gecko/20110812 Firefox/8.0a1).  Perhaps you were still on the previous build, which still had the previous patch?  That one was much easier to trigger by mistake in my opinion.

It honors the setting under Mouse -> More Gestures -> Swipe between pages, just like Safari does.  (well, minus the animations, of course).
If the System Preferences checkbox is disabled, swipes won't trigger any action in Firefox; if it's set to 'Scroll left or right with one finger', it requires one-finger swipes in Firefox; if it's set to 'Swipe left or right with two fingers', it requires two-finger swipes in Firefox.
Thanks, Emanuele, for your tests!

I've gone ahead and landed my patch for bug 668953 on aurora (which should, if all goes well, get it into FF7).

Comment 8

7 years ago
You are right, I was using an older build. Since the new version isn't as easy to activate by mistake, I'll keep the preference switched on. Good job on getting this working, we can probably resolve this bug as fixed.
Or rather as duplicate.
No longer blocks: 636455
Status: NEW → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 668953
Resolution: --- → DUPLICATE
Duplicate of bug: 668953

Comment 10

7 years ago
Bug 668953 says it's RESOLVED, but it still won't work on any of the latest release/beta/alpha channels (all up-to-date as of today).

Again, this is about *Magic Mouse* back-fwd gestures; the trackpad two/three-finger back/fwd works fine.

Comment 11

3 years ago
This bug has not been resolved, Iam using OS X Yosemite and I have this problem only in the latest FF, Chrome and Safari work fine. I have also noticed the gestures seem to work on FF build in pages such as about:addons but not on ordinary sites such as google.com.
I've just tested the "swipe between pages" gesture my Apple Magic Mouse on OS X 10.10.3, using Firefox 38.0.5 and today's mozilla-central nightly.  It worked just fine.  So clearly this bug is fixed in the general case, as was reported in comment #6.

Make sure sure support for the "Swipe between gestures" gesture is turned on (in the Mouse pref panel under the More Gestures tab) -- it doesn't seem to be on by default on OS X 10.10.

If that doesn't fix the problem, then try restarting Firefox in Safe Mode (Help : Restart with Add-ons Disabled).
You need to log in before you can comment on or make changes to this bug.