Closed Bug 676170 Opened 9 years ago Closed 9 years ago

Assertion when clicking the Profile link on facebook

Categories

(Firefox :: Session Restore, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 669196

People

(Reporter: ehsan, Unassigned)

Details

I had a facebook tab open showing my wall, and I realized that it has stopped updating.  I then hit Cmd+R and the Reload button, but nothing happened, except for this on the error console:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.getEntryAtIndex]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///components/nsSessionStore.js :: sss_serializeSessionStorage :: line 1888"  data: no]
Source File: resource:///components/nsSessionStore.js
Line: 1888

I then clicked the Profile link on the top right, and I got this assertion:

ASSERT: SessionStore failed gathering complete history for the focused window/tab. See bug 669196.
Stack Trace: 
0:sss_collectTabData([object XULElement])
1:sss_saveWindowHistory([object ChromeWindow])
2:sss_collectWindowData([object ChromeWindow])
3:([object ChromeWindow])
4:sss_forEachBrowserWindow(function (aWindow) {
    if (!this._isWindowLoaded(aWindow)) {
        return;
    }
    if (aUpdateAll ||
        this._dirtyWindows[aWindow.__SSi] || aWindow == activeWindow) {
        this._collectWindowData(aWindow);
    } else {
        this._updateWindowFeatures(aWindow);
    }
})
5:sss_getCurrentState(undefined,false)
6:sss_saveState()
7:sss_observe([xpconnect wrapped nsITimer],timer-callback,null)

Clicking on it again worked correctly.

This is my build ID: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110727 Firefox/8.0a1

(Today was my birthday, so my facebook wall had a very busy day, updating every few minutes.)
Blocks: 669196
Trying to bring up the back/forward menu from the toolbar button causes this:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.getEntryAtIndex]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/browser.js :: FillHistoryMenu :: line 8786"  data: no]
The assertion was added a bit ago, but I missed the error you're seeing. That should be gone in tomorrow's build.

Either way, close that tab and make sure your sessionstore.js is up to date. Chances are it hasn't updated since and you'll lose data.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669196
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.