CSS text-decoration img Bug; Img in paragraph cant get his own styles!

RESOLVED FIXED in mozilla8

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dreweso, Unassigned)

Tracking

unspecified
mozilla8
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 550365 [details]
minimal.zip - minimal style settings which doesn't work; test.html and the a text gfx

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 ( .NET CLR 3.5.30729)
Build ID: 20110614230723

Steps to reproduce:

I tried to underline my h2 tags with css
and after that i treied to remove the underline from an img which is underlined.
so just look at the code and you will see!


Actual results:

the img object gets underlined


Expected results:

the img tag should not get underlined.
(Reporter)

Comment 1

6 years ago
i tried the minimal at firefox 3.6.x
and 5
but it works still fine at ie 5.5 to 8 
and chrome

Comment 2

6 years ago
Maybe duplicate of Bug 403524

Comment 3

6 years ago
Should certainly revisit once that's fixed.

The rendering of the testcase is certainly correct per what CSS2.1 used to say.
Depends on: 403524

Updated

6 years ago
Attachment #550365 - Attachment mime type: application/octet-stream → application/zip
Once bug 403524 lands, img elements won't get underlined, ever (which is what CSS 2.1 requires).

Comment 5

6 years ago
As per Comment 4, the patch for 403524 guarantees that nothing but text gets decorations.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.