Last Comment Bug 676315 - ANGLE build problem: d3dx9.h not found unless $DXSDK_DIR points to it, since bug 641630 landed
: ANGLE build problem: d3dx9.h not found unless $DXSDK_DIR points to it, since ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 11:02 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-08-10 15:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix ANGLE build: find DXSDK headers (1.78 KB, patch)
2011-08-03 11:02 PDT, Benoit Jacob [:bjacob] (mostly away)
joe: review+
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-08-03 11:02:51 PDT
Created attachment 550431 [details] [diff] [review]
fix ANGLE build: find DXSDK headers

As it turns out, our new ANGLE Makefiles only use DXSDK_DIR to look for headers.
Comment 1 Joe Drew (not getting mail) 2011-08-04 14:31:20 PDT
Comment on attachment 550431 [details] [diff] [review]
fix ANGLE build: find DXSDK headers

Review of attachment 550431 [details] [diff] [review]:
-----------------------------------------------------------------

Is MOZ_DIRECTX_SDK_PATH guaranteed to always be set?

::: gfx/angle/src/libEGL/Makefile.in
@@ +63,5 @@
> +LOCAL_INCLUDES = \
> + -I$(srcdir)/../../include \
> + -I$(srcdir)/.. \
> + -I"$(DXSDK_DIR)/include" \
> + -I"$(MOZ_DIRECTX_SDK_PATH)/include" \

These should be indented two spaces, I think.

::: gfx/angle/src/libGLESv2/Makefile.in
@@ +63,5 @@
> +LOCAL_INCLUDES = \
> + -I$(srcdir)/../../include \
> + -I$(srcdir)/.. \
> + -I"$(DXSDK_DIR)/include" \
> + -I"$(MOZ_DIRECTX_SDK_PATH)/include" \

Same here.
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-08-04 14:35:58 PDT
(In reply to comment #1)
> Comment on attachment 550431 [details] [diff] [review] [diff] [details] [review]
> fix ANGLE build: find DXSDK headers
> 
> Review of attachment 550431 [details] [diff] [review] [diff] [details] [review]:
> -----------------------------------------------------------------
> 
> Is MOZ_DIRECTX_SDK_PATH guaranteed to always be set?

Yes. So actually I just realized that checking DXSDK_DIR here is useless and could even cause trouble in case of multiple DXSDKs installed. OK to remove DXSDK_DIR here?

> 
> ::: gfx/angle/src/libEGL/Makefile.in
> @@ +63,5 @@
> > +LOCAL_INCLUDES = \
> > + -I$(srcdir)/../../include \
> > + -I$(srcdir)/.. \
> > + -I"$(DXSDK_DIR)/include" \
> > + -I"$(MOZ_DIRECTX_SDK_PATH)/include" \
> 
> These should be indented two spaces, I think.

I was wondering. If I indent this with two spaces, will these two spaces end up in the command line? That's what I was trying to avoid.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-08-10 15:56:57 PDT
http://hg.mozilla.org/mozilla-central/rev/9c43ba0259fa

Note You need to log in before you can comment on or make changes to this bug.