Closed Bug 676321 Opened 9 years ago Closed 9 years ago

Sidebar briefly shows up on orientation change while using form autocomplete

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 9

People

(Reporter: lucasr, Assigned: lucasr)

Details

Attachments

(6 files, 5 obsolete files)

44.37 KB, image/png
Details
1.27 KB, patch
lucasr
: review+
Details | Diff | Splinter Review
1.17 KB, patch
lucasr
: review+
Details | Diff | Splinter Review
837 bytes, patch
lucasr
: review+
Details | Diff | Splinter Review
1.23 KB, patch
lucasr
: review+
Details | Diff | Splinter Review
1.01 KB, patch
lucasr
: review+
Details | Diff | Splinter Review
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622105737

Steps to reproduce:

Steps to reproduce:

1. Focus on an HTML form entry that has autocomplete suggestions, make sure it has a few suggestions.
2. While the autocomplete popup is visible, change the device orientation from landscape to portrait.


Actual results:

The left sidebar briefly shows up and slides out.


Expected results:

The left sidebar should not be visible at any time when changing device orientation.
This seems to be caused by popup being a bit too wide and causing the left sidebar to show up when orientation changes. Taking.
Assignee: nobody → lucasr.at.mozilla
Attached image screenshot
I had 7 tabs open (causing more than 1 column of tabs to appear in the sidebar) in landscape, and then shifted to portrait.  The bottom portion of the form page was checkerboarded, and the tab was partially out.

This was at http://people.mozilla.com/~nhirata/html_tp/formsninput.html
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch Fixes in code comment (obsolete) — Splinter Review
Attachment #554046 - Flags: review?(mbrubeck)
Attachment #554047 - Flags: review?(mbrubeck)
Attachment #554049 - Flags: review?(mbrubeck)
Attached patch Small coding style fix (obsolete) — Splinter Review
Attachment #554050 - Flags: review?(mbrubeck)
Attachment #554046 - Flags: review?(mbrubeck) → review+
Attachment #554047 - Flags: review?(mbrubeck) → review+
Attachment #554048 - Flags: review?(mbrubeck) → review+
Attachment #554049 - Flags: review?(mbrubeck) → review+
Attachment #554050 - Flags: review?(mbrubeck) → review+
Keywords: checkin-needed
Lucas, could you please provide patches whose commit message includes the bug number and "r=mbrubeck"? That would be really helpful.
Attachment #554050 - Attachment is obsolete: true
Attachment #554384 - Flags: review+
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110927
Firefox/9.0a1 Fennec/9.0a1
Device: Acer ICONIA A500
OS: Android 3.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.