Opening menu gives "ASSERTION: Filtered insertion point wasn't properly constructed"

RESOLVED FIXED in mozilla0.9

Status

()

P3
normal
RESOLVED FIXED
18 years ago
11 years ago

People

(Reporter: axel, Assigned: dr)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When opening a menu that hasn't been opened before, I get a 

###!!! ASSERTION: Filtered insertion point wasn't properly constructed.
: 'Error', file /tmp/mozilla/layout/xbl/src/nsXBLBinding.cpp, line 671
###!!! Break: at file /tmp/mozilla/layout/xbl/src/nsXBLBinding.cpp, line 671

I think that menus only trigger that bug, so I CC hyatt.

Tested on cvs from Feb, 5th. Feb, 1st was ok.

Axel

Comment 1

18 years ago
I'm seeing this ASSERTION hit like 13 times when starting up the browser so it's 
not just opening menus.

It's really annoying on windows because we get a dialog for each assertion.

After the browser comes up, I can get the assertion to be thrown by clicking in 
a window from another app so that it gets focus, and then just moving my mouse 
over the browser window in the background.

Comment 2

18 years ago
I should also mention the assertions are happening after I choose my profile, 
and that I'm seeing the following WARNING printed 4 times above the 
filtered insertion point assertion in my console:

WARNING: XBL load did not complete until after document went away! Modal dialog
bug?
, file y:\mozilla\layout\xbl\src\nsXBLService.cpp, line 340
--> hyatt
Assignee: pinkerton → hyatt

Comment 4

18 years ago
This has been caused by Ben's checkin.  His new menu bindings are malformed.  
XBL is behaving correctly by asserting.  The menu bindings should be reverted.
Assignee: hyatt → ben
Backed out my changes to the menu bindings. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
This is still happenning on a CVS pull from 11am EST on NT. I get two assertions 
on startup and a number on just clicking on the Bookmarks Item in the Personal 
Toolbar.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

18 years ago
OS: Solaris → All
Hardware: Sun → All

Comment 7

18 years ago
I see this with the modern skin. Do those bindings need fixing also?

Comment 8

18 years ago
I'm seeing this once on startup, with the modern skin.  I'm also seeing one:
###!!! ASSERTION: The prototype binding has somehow lost its XBLDocInfo! Bad bad
bad!!!
: 'info', file nsXBLPrototypeBinding.cpp, line 334

Comment 9

18 years ago
*** Bug 68088 has been marked as a duplicate of this bug. ***
sorry not a real diff, but the patch is tiny:


 RCS file: /cvsroot/mozilla/xpfe/global/resources/content/xulBindings.xml,v
 <       <children includes="menupopup,template"/>
 ---
 >       <children includes="menupopup|template"/>
 RCS file: /cvsroot/mozilla/xpfe/global/resources/content/menulistBindings.xml,v
 194c194
 <       <children includes="menupopup,template"/>
 ---
 >       <children includes="menupopup|template"/>
 204c204
 <       <children includes="menupopup,template"/>
 ---
 >       <children includes="menupopup|template"/>

Comment 12

18 years ago
r=sfraser. works for me.

Comment 13

18 years ago
can we get this approved and checked in?
Status: REOPENED → NEW
Keywords: approval, mozilla0.8.1
(Assignee)

Comment 14

18 years ago
i'll take care of it
Assignee: ben → dr
Priority: -- → P3
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 15

18 years ago
I fixed this already.
(Assignee)

Comment 16

18 years ago
figured.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.