Last Comment Bug 676846 - [about:permissions] Basic Auth Passwords not taken into Account
: [about:permissions] Basic Auth Passwords not taken into Account
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 9
Assigned To: Felix Fung (:felix)
:
Mentors:
Depends on:
Blocks: 573176
  Show dependency treegraph
 
Reported: 2011-08-05 08:41 PDT by Stephen Sagers
Modified: 2011-09-27 03:38 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Image showing the issue. (120.92 KB, image/jpeg)
2011-08-05 08:41 PDT, Stephen Sagers
no flags Details
findLogins should ignore httpScheme (1.42 KB, patch)
2011-09-15 15:39 PDT, Felix Fung (:felix)
dolske: review+
margaret.leibovic: feedback+
Details | Diff | Splinter Review

Description Stephen Sagers 2011-08-05 08:41:57 PDT
Created attachment 551045 [details]
Image showing the issue.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110805 Firefox/8.0a1
Build ID: 20110805030744

Steps to reproduce:

Went to about:permissions, typed a domain for which I had Basic Auth credentials saved into the 'Search Sites' box.


Actual results:

Under the Store Passwords section, it says '0 passwords are stored for this web site.' and the Manage Passwords... button is disabled.


Expected results:

Should display how many passwords I have, and enable the Manage Passwords... button.

I can clear the 'Search Sites' box (so I am just looking at All Sites) and click on the Manage Passwords... button.  Then search for the domain that I have the saved Basic Auth credentials, and it shows my saved passwords for that domain.
Comment 1 XtC4UaLL [:xtc4uall] 2011-08-07 07:32:07 PDT
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110807 Firefox/8.0a1 ID:20110807030727

PS. Site Visits do work.
Comment 2 Felix Fung (:felix) 2011-09-15 15:39:05 PDT
Created attachment 560474 [details] [diff] [review]
findLogins should ignore httpScheme

Summary of Changes
- Changed last parameter of findLogins from null to "". When it's null, it won't match anything with a login scheme (e.g. Mozilla LDAP) where as "" will freely match against anything.
Comment 3 :Margaret Leibovic 2011-09-15 15:50:37 PDT
Comment on attachment 560474 [details] [diff] [review]
findLogins should ignore httpScheme

This makes sense to me, but Dolske would better understand the implications of this change, since he's more familiar with the login manager code.

I also think you should leave that comment in there, since it still won't find logins that could be stored with different URIs from that host.
Comment 4 Justin Dolske [:Dolske] 2011-09-22 19:09:49 PDT
Comment on attachment 560474 [details] [diff] [review]
findLogins should ignore httpScheme

Seems fine to me.
Comment 5 Daniel Holbert [:dholbert] 2011-09-26 15:03:17 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/95a1d14917c4
Comment 6 Ed Morley [:emorley] 2011-09-27 03:38:30 PDT
https://hg.mozilla.org/mozilla-central/rev/184cfbecb1c3

Note You need to log in before you can comment on or make changes to this bug.