Since 20110805 Nightly8.0a1, Crash Reporter always sends signature: xul.dll@xxxxx, does not send exact signature.

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: armenzg)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/be090ee1747a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110806 Firefox/8.0a1 ID:20110806030740

Since 20110805 Nightly8.0a2, Crash Reporter always sends signature: xul.dll@xxxxx like a hourly build, does not send not exact signature.

Reproducible: Always

Steps to Reproduce:

1. Start browser
2. Crash browser
3.

Actual Results: 
  always sends signature: xul.dll@xxxxx

Expected Results: 
  Should send exact signature.
(Reporter)

Comment 1

6 years ago
regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/be4b064f1159
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110804 Firefox/8.0a1 ID:20110804030732
Fails:
http://hg.mozilla.org/mozilla-central/rev/5684f06138f3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110805 Firefox/8.0a1 ID:20110805030744
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4b064f1159&tochange=5684f06138f3
(Reporter)

Updated

6 years ago
OS: Windows XP → Windows 7
Summary: Since 20110805 Nightly8.0a2, Crash Reporter always sends signature: xul.dll@xxxxx, does not send not exact signature. → Since 20110805 Nightly8.0a2, Crash Reporter always sends signature: xul.dll@xxxxx, does not send exact signature.
(Reporter)

Updated

6 years ago
Summary: Since 20110805 Nightly8.0a2, Crash Reporter always sends signature: xul.dll@xxxxx, does not send exact signature. → Since 20110805 Nightly8.0a1, Crash Reporter always sends signature: xul.dll@xxxxx, does not send exact signature.
(Reporter)

Updated

6 years ago
Component: Breakpad Integration → Release Engineering
Product: Toolkit → mozilla.org
QA Contact: breakpad.integration → release
Version: Trunk → other

Comment 2

6 years ago
Bug 674888 looks like the likely culprit.
Blocks: 674888
That doesn't seem very likely at all. This regression is on Windows, and elfhack is for Linux...
There's definitely something broken in the symbol files.
Here's the 2011-08-04 nightly:
[tmielczarek@dm-symbolpush01 symbols_ffx]$ ls *8.0*WINNT*20110804*
firefox-8.0a1-WINNT-20110804030732-symbols.txt

$ grep xul firefox-8.0a1-WINNT-20110804030732-symbols.txt
xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.sym
xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.pd_

$ wc -l xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.sym
913346 xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.sym

$ grep FUNC xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.sym | wc -l
94942

$ grep STACK xul.pdb/318E544510FB4AC18A9D1EA389E96EA02/xul.sym | wc -l
49235

compare to the 2011-08-05 nightly:
$ ls *8.0*WINNT*20110805*
firefox-8.0a1-WINNT-20110805030744-symbols.txt

$ grep xul firefox-8.0a1-WINNT-20110805030744-symbols.txt
xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.sym
xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.pd_

$ wc -l xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.sym
947617 xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.sym

$ grep FUNC xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.sym | wc -l
103263

$ grep STACK xul.pdb/2B6071C4E2AA4ADE9E1BDF997836E06F2/xul.sym | wc -l
0

I don't know exactly what's going wrong though.

Updated

6 years ago
No longer blocks: 674888
Looking at the buildbot log for the Aug 5th nightly (m-c, win32) [1] then the magic id for xul.pdb is A0E701116B654E4DAB312A879E1962532 rather than 2B6071..., and it turns out that the Win64 and Win32 builds are overwriting each others manifest files (symbols.txt). The Win64 sym files don't have any STACK lines (is that a bug?). 

Since we still have separate sym files for the two platforms the crash should still be resolved on Socorro. We've also been overwriting the manifests for many days.

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1312538864/mozilla-central-win32-nightly-build9.txt.gz
(Reporter)

Comment 6

6 years ago
Today's Nightly8.0a1 seems to work properly again.

http://hg.mozilla.org/mozilla-central/rev/b422fd99fe0d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110807 Firefox/8.0a1 ID:20110807030727
Nick: oh, good call. We should fix that manifest overwriting though, because it is going to screw our ability to clean up symbols...

(The Win64 symbols not having STACK lines is bug 548035.)
Bug 677116 for the manifest naming fix.
(Assignee)

Updated

6 years ago
Assignee: nobody → armenzg
Priority: -- → P2
(Assignee)

Comment 9

6 years ago
This did get fixed now that bug 677116 got fixed?
Depends on: 677116
(Assignee)

Comment 10

6 years ago
Please reopen if it did not get fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.