Alt+Enter should always open in a new tab even if the current tab is a New Tab

VERIFIED WONTFIX

Status

()

defect
VERIFIED WONTFIX
8 years ago
3 months ago

People

(Reporter: bugzilla.mozilla.simon, Unassigned)

Tracking

({regression})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110724144355

Steps to reproduce:

1. Press Ctrl-T to open a New Tab
2. Enter "google.com" in the address bar and press Alt+Enter


Actual results:

Google loads in the current "New Tab" tab


Expected results:

Another new tab is opened and Google loads in this new tab

The behaviour is also inconsistent as about:blank is titled "New Tab" but it doesn't reuse the current "New Tab" tab if it has any history

Comment 1

8 years ago
This was the behavior in FF 3.6, correct?
Severity: normal → enhancement
OS: Linux → All
Hardware: x86_64 → x86

Comment 2

8 years ago
Last good nightly: 2010-12-10
First bad nightly: 2010-12-11

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a4544a4b3224&tochange=e42d81b3e0cc

The first bad revision is:
changeset:   59104:5113288ca83e
user:        Drew Willcoxon <adw@mozilla.com>
date:        Fri Dec 10 18:32:14 2010 -0800
summary:     Bug 596485 - Provide visual indication of Switch to Tab override. r=gavin, a=blocking-betaN

http://hg.mozilla.org/mozilla-central/rev/5113288ca83e
Keywords: regression
(Reporter)

Comment 3

8 years ago
(In reply to Tim (fmdeveloper) from comment #1)
> This was the behavior in FF 3.6, correct?

Yes, this was the behaviour in 3.6.18.

Comment 4

8 years ago
Still an issue with Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909030839

Going to confirm for now.

Drew -> Was this an intentional change?
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 5 Branch → Trunk
This change was intentional. (bug 596485 comment 14)
Blocks: 596485
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

8 years ago
Why is it intentional to ignore the user?

Using Enter on a "blank" tab opens the URL in the tab, using Alt+Enter ("open in a NEW tab") should open the URL in a new tab, not the current tab.

The behaviour is not consistent as an about:blank tab with no history is replaced, but an about:blank tab with history isn't replaced and a new tab opens.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to Simon Arlott from comment #6)
> Why is it intentional to ignore the user?

Because the unselected blank tab wouldn't be useful anymore.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

8 years ago
I'm using blank tabs to separate groups of open tabs, so don't try to tell me it's not useful. What's not useful is those tabs disappearing every time I open a URL in a new tab.
(In reply to Simon Arlott from comment #8)
> I'm using blank tabs to separate groups of open tabs, so don't try to tell
> me it's not useful.

Sorry, Firefox isn't designed to support this. There is however a feature called Panorama for managing tab groups.
(Reporter)

Comment 10

8 years ago
Bug 596485 refers to the "Switch to Tab" feature, so this was not an intentional change.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
See bug 596485 comment 14.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
Also bug 596485 comment 23 which mentions the non-switch-to-tab case.
(Reporter)

Comment 13

8 years ago
So in the middle of a bug relating to the "Switch to Tab" feature being confusing because it overloads Alt-Enter, it's ok to change the existing behaviour of Alt-Enter when "Switch to Tab" isn't being used?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to Simon Arlott from comment #13)
> it's ok to change the existing
> behaviour of Alt-Enter when "Switch to Tab" isn't being used?

Yes, because it was done and reviewed consciously. I'm sorry, but your blank-tabs-separate-tab-groups use case is not a common one; optimizing for this isn't sane. Since you already managed to write a patch, maybe you're also capable of writing an extension to meet your needs (e.g. one that lets isTabEmpty always return false).
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX

Comment 17

5 years ago
Why exactly do you _allow_ us to open new tabs at all, isn’t that just a blank new tab? Shouldn’t you spawn a popup that says “You goof! Why open a new tab with nothing in it!”?

Keep it simple, stupid.

The shortcut for opening a new tab should open a new tab.
The shortcut for opening a new tab should open a new tab.
The shortcut for opening a new tab should open a new tab.

Read it until it sinks in.
(Reporter)

Comment 19

a year ago
Now that extensions can't modify Firefox will you finally fix this in the browser?

I'm fed up of having to patch every new release of Firefox for the last 7 years to fix this.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

You are free to fork the code or modify it locally, but it's pointless to keep reopening this bug, the behavior was decided years ago, it's unlikely to change at this point.

Please avoid insisting once decisions are made, the Bugzilla etiquette specifically says:
"No whining about decisions. If another project contributor has marked a bug as INVALID, then it is invalid. Filing another duplicate of it does not change this. Unless you have further evidence to support reopening a bug, do not post a comment arguing that a bug resolved as INVALID or WONTFIX should be reopened."
And we really don't want to involve admins.

Status: REOPENED → RESOLVED
Last Resolved: 8 years ago3 months ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.