Closed
Bug 677071
Opened 15 years ago
Closed 14 years ago
[OPSI] Win32 slaves should utilize runslave.py for SeaMonkey (Port Bug 616351)
Categories
(SeaMonkey :: Release Engineering, defect, P3)
Tracking
(Not tracked)
RESOLVED
FIXED
People
(Reporter: Callek, Unassigned)
References
()
Details
Bug 616351 adjusted the way buildbot is launched on the MoCo machines by adding runslave.py
Luckily the way the runslave.py sits today is actually usable by us without needing to fork it (we should add a few options just to make our life safer though)
Things runslave.py does that we won't be using with this bugs scope:
#1 It uses slavealloc to get/create buildbot.tac files on a per-slave basis.
*** slavealloc is overkill for us at the moment, we'll continue to use existing buildbot.tac files on the slave
*** runslave.py fails over to support this
*** we should pass an invalid slavealloc url as an argument to launch (suggest: slavealloc.seamonkey-project.org) If we ever use a real slavealloc we need to care that things other than our build network cannot access it! (passwords)
#2 Nagios Alerts
*** runslave.py internally supports reporting to Nagios. We don't have any nagios monitoring up yet, and the internal support is also mapped quite specificcally to the MoCo releng environ. Since we have no current efforts to establish nagios monitoring of our slaves, this is irrelevant for us.
Sample output of a brief test (including making the Nagios code run without actually trying to start buildbot):
C:\Documents and Settings\Administrator\Desktop>"D:\mozilla-build\python25\pytho
n" c:\runslave.py --allocator-url allocator.seamonkey-project.org --no-start
WARNING: error while fetching allocator.seamonkey-project.org
WARNING: falling back to existing buildbot.tac
Error sending notice to nagios (ignored)
I explicitly did not wish to go as far as deploying this on any slave just yet
| Reporter | ||
Updated•15 years ago
|
| Reporter | ||
Comment 1•14 years ago
|
||
We're now using this everywhere when we migrated off Parallels and rebuilt our VMs
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in
before you can comment on or make changes to this bug.
Description
•