The default bug view has changed. See this FAQ.

<noscript> content cannot be copied to clipboard

RESOLVED FIXED in mozilla8

Status

()

Core
Widget
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Stanimir Stamenkov, Assigned: mats)

Tracking

Trunk
mozilla8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 551334 [details]
NOSCRIPT sample

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20110731 SeaMonkey/2.3
Build ID: 20110731194239

Steps to reproduce:

While JavaScript is disabled, open the attached sample, select and copy *the complete content* (including the final dot) of the first <noscript> element to the clipboard, that is both of the following paragraphs:

    Select completely and copy both paragraphs to the clipboard.

    Then try to paste into a text editor.

As the sample suggest, then try to paste into a text editor.

Happens with current release as with latest nightly as well:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110807 Firefox/8.0a1


Actual results:

No content appeared with the paste operation.


Expected results:

The content of the <noscript> element just copied should have appeared in the text editor with the paste operation.
(Reporter)

Comment 1

6 years ago
This appears to happen with <noscript> elements containing two or more paragraphs (<p> elements) after selecting them completely.  Omitting one paragraph or just the last character in the last paragraph from selection, copies (and then pastes) the selected content fine.

Selecting completely, copying and pasting single paragraph, being the only content of a <noscript> element, also works fine.
(Reporter)

Updated

6 years ago
Attachment #551334 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 2

6 years ago
Don't know how this might be related but, selecting all of the content in the attached sample, copying it, then pastes just the heading "Copy noscript content test".
(Assignee)

Updated

6 years ago
Status: UNCONFIRMED → NEW
Component: DOM → Serializers
Ever confirmed: true
OS: Windows 7 → All
QA Contact: general → dom-to-text
Hardware: x86_64 → All
This isn't actually a serializer bug.

nsHTMLFormatConverter::ConvertFromHTMLToUnicode (which is called via nsCopySupport::HTMLCopy calling SelectionCopyHelper calling nsHTMLFormatConverter::Convert) initializes a plaintext serializer like so:

294       textSink->Initialize(&aToStr, nsIDocumentEncoder::OutputSelectionOnly
295                            | nsIDocumentEncoder::OutputAbsoluteLinks, 0);

note conspicuous lack of OutputNoScriptContent.   Compare the document encoder or web browser persist, which set that flag if script is disabled on the document or if told to do so explicitly respectively.

After that the serializer does exactly what it's been told to do.

This code looks like it hasn't changed from jst's initial checkin of nsHTMLFormatConverter back in Oct 2000...

The problem, of course, is that it's converting an HTML string to a plaintext string.  By this point it has no idea what document the HTML came from originally, as far as I can tell.
Component: Serializers → Widget
QA Contact: dom-to-text → general
(Assignee)

Comment 4

6 years ago
Created attachment 551480 [details] [diff] [review]
fix

I think can we can make nsHTMLFormatConverter::ConvertFromHTMLToUnicode
assume that the input HTML string is already filtered visavi noscript
and noframes - that is, if they occur in the input string they should be
included in the result.

Writing a test for that seems hard with script disabled.
I've added a test for the opposite...
Attachment #551480 - Flags: review?(bzbarsky)
Comment on attachment 551480 [details] [diff] [review]
fix

Ah, excellent.  r=me
Attachment #551480 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 6

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/2c7e0e31fc0c
Assignee: nobody → matspal
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
http://hg.mozilla.org/mozilla-central/rev/2c7e0e31fc0c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
You need to log in before you can comment on or make changes to this bug.