Closed Bug 677110 Opened 12 years ago Closed 12 years ago

firefox hangs on zoom

Categories

(Firefox :: General, defect)

8 Branch
x86_64
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 626963

People

(Reporter: dhillman86, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

1) start Firefox 5.0
2) go to http://www.plasmaphysics.org.uk/collision2d.htm
3) view/zoom in



Actual results:

the page turns a solid color and firefox hangs. (When I first found this, I had a zillion tabs open. I exited, restarted and the tabs were gone. Oh well.)


Expected results:

at the very least, it shouldn't hang
Able to confirm on Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110806 Firefox/8.0a1 ID:20110806030740

Looks like there is a prompt that is displayed when I zoom on 3.6. Relevant code is 

 function reload_window() { 
	 
	   firefox=-1;
       if (navigator.userAgent) { firefox=navigator.userAgent.search(/Firefox/);  } 
	   if (firefox==-1) { window.location.reload(); }
	      else { 
		      if (navigator.cookieEnabled) {
                 if ( document.cookie.indexOf('resize=') ==-1 ) {
                  alert('For best display, please reload the page after resizing your window');  
                  today = new Date();
                  expiry = new Date(today.getTime() + 24*60*60*1000);   // cookie expires after 1 day
                  document.cookie='resize=yes; expires='+expiry.toGMTString()+'; path=/'; 
				 }
			  }
			  else { alert('Please reload this page'); }
				
          }
		  
}

On nightly get the following error in the error console:

Error: uncaught exception: [Exception... "prompt aborted by user"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///components/nsPrompter.js :: openTabPrompt :: line 462"  data: no]
Version: 5 Branch → 8 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
WORKAROUND(The alert box to be a window modal instead of a tab modal)

set prompts.tab_modal.enabled to false.
WFM now,
http://hg.mozilla.org/mozilla-central/rev/131961e5e0d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120612030527

It works Firefox12 and later.
You need to log in before you can comment on or make changes to this bug.