Open Bug 677114 Opened 11 years ago Updated 5 years ago

Can't move out of the table cell while pressing the left arrow key in this case.

Categories

(Core :: DOM: Selection, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression, testcase)

See url for the testcase.
Steps to reproduce:
- Put the caret inside the table cell area.
- Press the left arrow key several times.

Notice how the caret stays in the table cell, no matter how often you press the left arrow key.

This regressed between 2009-06-23 and 2009-06-24:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-06-23+04%3A00%3A00&enddate=2009-06-24+06%3A00%3A00
After that, the caret disappeared completely. Current situation is a little different, now the caret goes to the end of the table cell.
I think this is a regression from bug 495385.
The url from the testcase is from bug 677113.
20160502172042 Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
20160523030225 Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on latest FF release 46.0.1 and latest Nightly build and could not reproduce it. 

Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.