Slow down to the point of hang but no spinning beachball

RESOLVED DUPLICATE of bug 412223

Status

Camino Graveyard
Tabbed Browsing
--
critical
RESOLVED DUPLICATE of bug 412223
6 years ago
6 years ago

People

(Reporter: Tanster, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 551392 [details]
Sampling file from Activity Monitor

I normally run up to 5 tabs per window and up to 3 windows.  Camino 2.0.7 on a PPC G5 running Leopard 10.5.8 slows down until it is practically unusable. Sometimes a spinning beachball shows up.  More often it doesn't.  However, clicking on any window takes forever for Camino to respond.  Ditto for clicking any hyperlink on any window.  CPU then hikes up to 90% or thereabouts but I can still switch to other apps which then run pretty quickly.  The same windows with the same number of tabs when opened in Safari 5.0.6 on the same hardware and OS run pretty fast.  Sampling the process shows that Camino seems to bog down with lots of semaphore_wait states.  I enclose a sampling file of Camino when it enters this state.
Flags: camino2.0.7+

Comment 1

6 years ago
FYI for future bug filing: flags are reserved for Camino developer use; do not set flags on bugs.

This is the same as bug 412223 (_enableOrDisableTrackingAreas / _disableTrackingArea); we never figured out what was causing it, but with with an up to date version of Flash we stopped seeing it, so you should check your Flash version. If that doesn't help, I'd suggest Camino 2.1b1, where nobody ever saw this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: camino2.0.7+
Resolution: --- → DUPLICATE
Duplicate of bug: 412223
You need to log in before you can comment on or make changes to this bug.