css3-3d-transforms isn't fully disabled since properties (which sites detect) are added to IDL

VERIFIED FIXED in Firefox 8

Status

()

Core
CSS Parsing and Computation
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Jean Claveau, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
mozilla9
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox6 unaffected, firefox8+ fixed)

Details

(Whiteboard: [qa!] [verified-beta] [verified-aurora])

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Steps to Reproduce
---------------------------------------
1. go to http://dev.openclic.fr/
2. click on arrows arround the photo
3.

What should have happened:
---------------------------------------
Photos should slide (using css -moz-transition)



What actually happened:
----------------------------------------
they don't
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows XP → Linux
Version: 3.5 Branch → 8 Branch

Comment 1

6 years ago
Regression window(m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/3735fb1cd5ef
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 ID:20110803030753
Fails:
http://hg.mozilla.org/mozilla-central/rev/c35c69e1ce99
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110803 Firefox/8.0a1 ID:20110803015018
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3735fb1cd5ef&tochange=c35c69e1ce99

Regression window(m-i hourly):
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/29232fea6e19
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110802 Firefox/8.0a1 ID:20110802200330
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/166f4f247772
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110802 Firefox/8.0a1 ID:20110802200834
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=29232fea6e19&tochange=166f4f247772
Triggered by:
Bug 505115 - CSS3 3D-Transforms
Blocks: 505115
Component: General → Style System (CSS)
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: general → style-system
tracking-firefox8: --- → ?
From http://dev.openclic.fr/css/all.css:

  html.no-csstransforms .slideshow.horizontal > ol.slides > li.current {
    left:0;
  }
  html.csstransforms.no-csstransforms3d .slideshow.horizontal > ol.slides >
   li.current {
    -moz-transform:translateX(0);
    -webkit-transform:translateX(0);
    -o-transform:translateX(0);
    -ms-transform:translateX(0);
    transform:translateX(0);
  }
  html.csstransforms3d .slideshow.horizontal > ol.slides > li.current {
    -webkit-transform:translate3d(0, 0, 0);
    transform:translate3d(0, 0, 0);
  }

So the site assumes that if .csstransforms3d is set then the browser must be either WebKit or implement unprefixed 3D transforms.

Unfortunately, that class _is_ set in a current nightly, because the site is using Modernizr, which looks for a "MozPerspective" property, which we now have as a result of the patches in bug 505115.
Assignee: nobody → french
Status: UNCONFIRMED → NEW
Component: Style System (CSS) → French
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: style-system → french
Version: 8 Branch → unspecified
I sent them mail, but if someone who can write French sanely wants to do that too, that would be great!
(Reporter)

Comment 4

6 years ago
What do you want to translate in french? I'm one of the devs of this website if you mean us by "them".


Here is your explanation translated (in case it's what you want to translate) :
Donc, le site considère que si .csstransforms3d est défini, le navigateur doit être WebKit ou implémenter les transformations 3D sans préfixe.

Malheureusement, cette classe EST définie avec la nightly actuelle puisque le site utilise Modernizr, qui cherche la propriété "MozPerspective" qui, comme nous le savons, donne le résultat des patches du bug 505115.

I supposed the "now" in the last line is a "know".
> I'm one of the devs of this website if you mean us by "them".

Yep, that's exactly what I meant by "them".  If you're here, then there's no point translating anything to French as long as you're happy reading my English.  Not much point in me sending feedback through the form on the site if you're reading this bug already.  :)

> I supposed the "now" in the last line is a "know".

No, it's "now".  As in, we did not use to have it, and now we do have it.

I suspect that just adding a -moz-transform:translate3d to that last CSS block from comment 2 and likewise for the other several places this selector pattern appears should help.  You should probably add the -o- and -ms- versions too.
(Reporter)

Comment 6

6 years ago
That's what I guessed reading you. I'm the server-side dev/admin so I haven't dug enough.
Anyway, it's a great news to see 3D transforms available in Firefox!
I will make the needed changes tomorrow.

I hope there are not too much webkitists like my client-side dev. It may cause trouble when ffx 8 will be the rc (I'm the Linux-Mozillist of the team ).

"...no point... Not much point...", I'll probably be happy to read your english for a while as it shows me how to improve my own. :)

By the way, the last sentence becomes :
Malheureusement, cette classe EST définie avec la nightly actuelle puisque le site utilise Modernizr, qui cherche la propriété "MozPerspective" que nous avons depuis les patches du bug 505115.

Thank you very much for your lights.
> I will make the needed changes tomorrow.

Thanks!

> It may cause trouble when ffx 8 will be the rc

Yeah, that's what we have a 3-month testing period for. :)
(Reporter)

Comment 8

6 years ago
I added the rules to the css :
html.csstransforms3d .slideshow.horizontal > ol.slides > li.current {

	-webkit-transform:translate3d(0, 0, 0);

	-moz-transform:translate3d(0, 0, 0);

	-o-transform:translate3d(0, 0, 0);

	-ms-transform:translate3d(0, 0, 0);

	transform:translate3d(0, 0, 0);

}

Nothing changed... The slides don't move. And firebug doesn't show the rule.
Let's be patient!
Hmm.  That's a problem on our end.  It looks like all.js has:

  pref("layout.3d-transforms.enabled, false);

(ignoring for the moment that it's missing a '"' there) but the IDL properties are added unconditionally.  That's not good.
Assignee: french → matt.woodrow
Component: French → Style System (CSS)
Product: Tech Evangelism → Core
QA Contact: french → style-system
(Reporter)

Comment 10

6 years ago
I added it via about:config.

There is no animation but the photos move. If I change too much times, ffx chrashes.
Summary: [QAC generated] Transitions don't work anymore on 8.0a1 (2011-08-07) → css3-3d-transforms isn't fully disabled since properties (which sites detect) are added to IDL
Adding crash signature so it gets picked up on the Socorro side.
Crash Signature: [@ mozilla::css::ComputeCalc<LengthPercentPairCalcOps> ]
This bug is not about a crash.
Crash Signature: [@ mozilla::css::ComputeCalc<LengthPercentPairCalcOps> ]
(Assignee)

Comment 13

6 years ago
Created attachment 553088 [details] [diff] [review]
Remove the IDL properties for now
Attachment #553088 - Flags: review?(dbaron)
Comment on attachment 553088 [details] [diff] [review]
Remove the IDL properties for now

r=dbaron

Sorry for the delay getting to this.



We need to get this in on aurora to fix the fact that something that was supposed to be disabled wasn't fully disabled.
Attachment #553088 - Flags: review?(dbaron)
Attachment #553088 - Flags: review+
Attachment #553088 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #553088 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 15

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/6409a44ecb17
Whiteboard: [inbound]
(Assignee)

Comment 16

6 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/e55d507e6a6b
status-firefox8: --- → fixed
Backed on Aurora and Inbound because of test failures:
hg.mozilla.org/releases/mozilla-aurora/rev/ebe4b5370436
https://hg.mozilla.org/integration/mozilla-inbound/rev/2586082fbd94
status-firefox8: fixed → affected
Whiteboard: [inbound]
(Assignee)

Comment 18

6 years ago
This is failing lots of tests because the properties still exist in property_database.js. I've tried removing those too, but multiple tests also check css_properties.js and fail there.

Any idea how we can get these tests to pass?
Does it work if you:
 * comment out the bits of property_database.js
 * hack ListCSSProperties.cpp to exclude them?
(Assignee)

Comment 20

6 years ago
Created attachment 555325 [details] [diff] [review]
Remove the IDL properties for now v2

Looks like it does, yes. Thanks!

Try push: http://tbpl.allizom.org/?tree=Try&usebuildbot=1&pusher=mwoodrow@mozilla.com
Attachment #555325 - Flags: review?(dbaron)
(Assignee)

Comment 21

6 years ago
Created attachment 556341 [details] [diff] [review]
Remove the IDL properties for now - mozilla-central

Also remove the -moz-transform-style properties on mozilla-central
Attachment #556341 - Flags: review?(dbaron)
Comment on attachment 555325 [details] [diff] [review]
Remove the IDL properties for now v2

r=dbaron
Attachment #555325 - Flags: review?(dbaron) → review+
Comment on attachment 556341 [details] [diff] [review]
Remove the IDL properties for now - mozilla-central

r=dbaron
Attachment #556341 - Flags: review?(dbaron) → review+
(Assignee)

Comment 24

6 years ago
Landed on inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/0c6cbf58eaa0
(Assignee)

Comment 25

6 years ago
And on Aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/03b0d42603f8
http://hg.mozilla.org/mozilla-central/rev/0c6cbf58eaa0
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
Version: unspecified → Trunk

Updated

6 years ago
status-firefox8: affected → fixed
tracking-firefox8: ? → +
Cannot reproduce on Firefox 6.0.2 Linux using the testcase in the original comment. Based on check-ins I don't think this should be fixed in 6.0.2.

Can someone please either confirm that 6.0.2 is fixed or provide a test case which reproduces this bug so that QA can verify? Thanks.
Whiteboard: [qa+]
The CSS 3d-transforms patches that caused this bug never landed on 6.
status-firefox6: --- → unaffected
Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (X11; Linux i686; rv:9.0a2) Gecko/20111007 Firefox/9.0a2
Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111007 Firefox/10.0a1


Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111004 Firefox/9.0a2 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111005 Firefox/10.0a1

Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0a2) Gecko/20111006 Firefox/9.0a2
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111006 Firefox/10.0a1

Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111006 Firefox/9.0a2
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111006 Firefox/10.0a1


Photos at link mentioned in bug description slide using the -moz-transition properties; Firebug shows the following rules:
-moz-transition-duration: 0.3s
-moz-transition-property: margin
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!] [verified-beta] [verified-aurora]
You need to log in before you can comment on or make changes to this bug.