Last Comment Bug 677466 - Add memory reporter for the atoms table
: Add memory reporter for the atoms table
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Nicholas Nethercote [:njn]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: DMD
Blocks: DarkMatter
  Show dependency treegraph
 
Reported: 2011-08-09 00:09 PDT by Nicholas Nethercote [:njn]
Modified: 2011-08-10 08:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.42 KB, patch)
2011-08-09 00:09 PDT, Nicholas Nethercote [:njn]
luke: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-08-09 00:09:13 PDT
Created attachment 551685 [details] [diff] [review]
patch

DMD found that the atoms table is quite big.  E.g. after loading Gmail it's just over 2MB (1.5%) on my Linux64 box.

This patch also adds a "runtime" reporter, which is 282KB on my box.  Not that big, but doesn't hurt to include it.
Comment 1 Luke Wagner [:luke] 2011-08-09 09:00:11 PDT
Comment on attachment 551685 [details] [diff] [review]
patch

Review of attachment 551685 [details] [diff] [review]:
-----------------------------------------------------------------

On the subject of the large atom state, it would be interested to measure how many of those atoms have been "interned" since interned strings are never swept and thus could be a source of leaks.  This is pretty easy to derive (see js_TraceAtomState).

Note You need to log in before you can comment on or make changes to this bug.