Last Comment Bug 677648 - Fix c++0x initializer list error found by clang
: Fix c++0x initializer list error found by clang
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 12:35 PDT by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2011-08-11 12:07 PDT (History)
1 user (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
change the type of "advance" (1.59 KB, patch)
2011-08-09 12:35 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
roc: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-08-09 12:35:55 PDT
Created attachment 551857 [details] [diff] [review]
change the type of "advance"

The mAdvance field of DetailedGlyph is a PRInt32. Since the advance
    variable is used in
    
    DetailedGlyph detail = {glyphIndex, advance, 0, 0};
    
    it should be a PRInt32 instead of a PRUint32. Let me know if I should try
    to change the field instead.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-08-11 12:07:11 PDT
http://hg.mozilla.org/mozilla-central/rev/90719558b5e2

Note You need to log in before you can comment on or make changes to this bug.