Last Comment Bug 677787 - Remove unique_pointer from typelib code
: Remove unique_pointer from typelib code
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 17:21 PDT by Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
Modified: 2011-10-14 13:36 PDT (History)
4 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.19 KB, patch)
2011-08-18 04:29 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review
Patch v1.1 (7.26 KB, patch)
2011-08-18 08:09 PDT, Ed Morley [:emorley]
no flags Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-09 17:21:41 PDT
It's completely unused.
Comment 1 Ed Morley [:emorley] 2011-08-18 04:29:08 PDT
Created attachment 554032 [details] [diff] [review]
Patch v1
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-18 04:38:14 PDT
Comment on attachment 554032 [details] [diff] [review]
Patch v1

Does typelib.py not need adjustments here?
Comment 3 Ed Morley [:emorley] 2011-08-18 06:53:39 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> Does typelib.py not need adjustments here?

Ah yes, the comments there can be removed too. Didn't show up in my local grep since I ran it from xpcom/typelib/ only, since MXR doesn't show occurrences in typelib.py due to out of date indexes :-(
Comment 5 Ed Morley [:emorley] 2011-08-20 04:30:49 PDT
New try push due to random tree breakage that was going on at the time:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=f701ded4c303

(That will teach me to pull from m-c tip when sending to try)

Like the other checkin-needed's I'll likely just do these myself once IT flip my L3 bits in bug 680448.
Comment 8 Eric Shepherd [:sheppy] 2011-10-14 13:36:53 PDT
Added a note to Firefox 9 for developers; since unique pointers appear never to have been fully implemented (let alone used), they were never documented, so this seems to be the most that needs doing (indeed it probably doesn't need mentioning at all).

Note You need to log in before you can comment on or make changes to this bug.