XSENDER with POP3 is not really used

VERIFIED DUPLICATE of bug 27191

Status

MailNews Core
Networking: POP
--
minor
VERIFIED DUPLICATE of bug 27191
17 years ago
9 years ago

People

(Reporter: Marian Eichholz, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Story: The POP3 protocol class requests an XSENDER and gets one by the server.

/1/ The server capabilities are initially hard wired to TRUE. This may be
offending for some systems that do not implement the unofficial XSENDER extension.

/2/ The nsPop3Protocol sets the MSG_FLAG_SENDER_AUTHED (0x200)
X-Mozilla-Status flag, but I found no location in the UI code, where this
flag is used.

/3/ There is an interface (m_nsIPop3Sink->SetSenderAuthedFlag()), but it is
called only once to *clear* the member flag, when the From-Header appears.

/4/ After all, the authenticated sender in the XSENDER reply is not used
(stored and retrieved) at all. It is stored into m_senderInfo but not passed
to the nsPop3Sink object.

After all, the concept of XSENDER seems to be somewhat useless at this
point.
(Reporter)

Comment 1

17 years ago
*** Bug 67780 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
related/dup of bug 27191 "Would like X-Sender functionality similar to
Communicator 4.7"

Comment 3

17 years ago
Dupe because its an argument on whether or not it should be implemented

*** This bug has been marked as a duplicate of 27191 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
verified dup
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.