All users were logged out of Bugzilla on October 13th, 2018

typed array inline slots break pdf.js

RESOLVED DUPLICATE of bug 677743

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 677743
7 years ago
7 years ago

People

(Reporter: gal, Assigned: nsm)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox7-, firefox8-, fennec-)

Details

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #664249 +++
(Reporter)

Updated

7 years ago
No longer depends on: 664249, 677743, 656519
(Reporter)

Updated

7 years ago
Blocks: 664249
No longer blocks: 650657
(Reporter)

Updated

7 years ago
Assignee: general → nsm.nikhil
(Reporter)

Comment 1

7 years ago
STR

Go to this page. Works with an 8/3 nightly, broken with this patch (paper isn't rendered).

andreasgal.github.com/pdf.js/web/viewer.html
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
tracking-firefox7: --- → ?
tracking-firefox8: --- → ?
Hopefully this is bug 677743, a PIC bug which is really easy to manifest when using typed arrays that are at varying byteOffsets into array buffers.  I saw this yesterday when merging to TI and will be pushing to inbound shortly.
tracking-fennec: ? → -

Comment 3

7 years ago
Andreas, I don't think the release drivers are the right team to be tracking or driving this. Probably better to get JS folks digging in to this. Or do you think that there's a Firefox release impact here for Firefox 7 or 8?
tracking-firefox7: ? → -
tracking-firefox8: ? → -
(Reporter)

Comment 4

7 years ago
The patch broke typed arrays, are very frequently used web feature. The patch has to be backed out or the bug fixed before we release.
I'm testing the fix for bug 677743 as we speak.
Confirmed that bug 677743 fixes pdf.js.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 677743

Comment 7

7 years ago
Andreas, thanks for the explanation. That's precisely the data I was missing that we needed to understand the tracking request.
(Reporter)

Comment 8

7 years ago
Sure, thanks for triaging :)
You need to log in before you can comment on or make changes to this bug.