Last Comment Bug 677864 - Components.results class description is wrong
: Components.results class description is wrong
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: arno renevier
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 02:36 PDT by arno renevier
Modified: 2011-08-21 11:42 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (390 bytes, text/html)
2011-08-10 02:36 PDT, arno renevier
no flags Details
patch proposal (6.65 KB, patch)
2011-08-10 08:13 PDT, arno renevier
mrbkap: review+
Details | Diff | Splinter Review
patch fixing tests (6.48 KB, patch)
2011-08-17 14:10 PDT, arno renevier
mrbkap: review+
Details | Diff | Splinter Review

Description arno renevier 2011-08-10 02:36:57 PDT
Created attachment 552040 [details]
testcase

Hi,
nsXPCComponents_Results class description is wrong.
See testcase.
Comment 1 arno renevier 2011-08-10 08:13:01 PDT
Created attachment 552082 [details] [diff] [review]
patch proposal
Comment 3 arno renevier 2011-08-17 14:10:07 PDT
Created attachment 553898 [details] [diff] [review]
patch fixing tests

It looks like test does not pass. I though I had submitted a correct test, but I did not qrefresh or whatever. Here is the same patch with updated test.
Comment 4 :Ehsan Akhgari 2011-08-17 14:11:47 PDT
Backed it out of inbound because of the test failure.
Comment 5 Mozilla RelEng Bot 2011-08-18 08:20:43 PDT
Try run for 1149bed204f1 is complete.
Detailed breakdown of the results available here:
    http://tbpl.mozilla.org/?tree=Try&rev=1149bed204f1
Results (out of 244 total builds):
    exception: 2
    success: 221
    warnings: 20
    failure: 1
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/arno@renevier.net-1149bed204f1
Comment 6 arno renevier 2011-08-18 09:03:11 PDT
Comment on attachment 553898 [details] [diff] [review]
patch fixing tests

correct link is http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=1149bed204f1
Comment 7 :Ehsan Akhgari 2011-08-19 12:28:05 PDT
Pushed to inbound.
Comment 8 :Ms2ger (⌚ UTC+1/+2) 2011-08-21 11:42:29 PDT
http://hg.mozilla.org/mozilla-central/rev/77704e4f395b

Note You need to log in before you can comment on or make changes to this bug.