Last Comment Bug 677897 - symbolstore.py should use objcopy from the NDK to copy debug info
: symbolstore.py should use objcopy from the NDK to copy debug info
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Breakpad Integration (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla10
Assigned To: Mike Hommey [:glandium]
:
: Ted Mielczarek [:ted.mielczarek]
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 07:24 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-10-18 12:42 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Use objcopy from the NDK in symbolstore.py (5.25 KB, patch)
2011-10-03 08:30 PDT, Mike Hommey [:glandium]
ted: review+
christian: approval‑mozilla‑aurora+
christian: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2011-08-10 07:24:51 PDT
Currently we don't get native debug symbols for our Android builds on the symbol server because we try to use the system objcopy on our binaries, and it chokes:
objcopy: Unable to recognise the format of the input file `./dist/bin/libxul.so'

We should be using the objcopy from the NDK instead:
android-ndk-r4c/build/prebuilt/linux-x86/arm-eabi-4.4.0/arm-eabi/bin/objcopy
android-ndk-r4c/build/prebuilt/linux-x86/arm-eabi-4.4.0/bin/arm-eabi-objcopy
Comment 1 Mike Hommey [:glandium] 2011-10-03 08:30:33 PDT
Created attachment 564194 [details] [diff] [review]
Use objcopy from the NDK in symbolstore.py
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-10-05 09:26:06 PDT
Comment on attachment 564194 [details] [diff] [review]
Use objcopy from the NDK in symbolstore.py

Review of attachment 564194 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +444,5 @@
>      MOZ_CHROME_FILE_FORMAT=omni
>      ZLIB_DIR=yes
>      ;;
> +*)
> +    OBJCOPY=objcopy

Do we want to AC_PATH_PROGS this?
Comment 3 Mike Hommey [:glandium] 2011-10-06 01:44:36 PDT
Comment on attachment 564194 [details] [diff] [review]
Use objcopy from the NDK in symbolstore.py

This could be something we'd want to land on beta and aurora, as it will allow us to download debuginfo for use with gdb on releases.
Comment 4 Ed Morley [:emorley] 2011-10-06 08:34:53 PDT
https://hg.mozilla.org/mozilla-central/rev/348e16153987

Note You need to log in before you can comment on or make changes to this bug.