Closed Bug 677912 Opened 9 years ago Closed 7 years ago

Title for a PNG image : display × instead of x, and put non-breaking spaces.

Categories

(Core :: Localization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: nicolas.barbulesco, Assigned: aceman)

References

Details

(Keywords: intl, polish)

Attachments

(1 file)

Hello,

Windows XP. Firefox 3.0.1.

I display a PNG image.
The window title displays:
20x18 pixels
I right-click, "View page info" : "General". Same display:
20x18 pixels
These displays are slightly incorrect.
Please put instead the correct display:
20 × 18 pixels
Primo, the letter x has nothing to do here. The right character is the "times" character × - www.fileformat.info/info/unicode/char/d7/index.htm .
Secundo, put non-breaking spaces around this character.

Thanks,

Nicolas
Really Firefox 3.0.1? No change will happen there, it is unsupported. However, on newer Firefox (like 5) this seems to still exist as described. But in Page info -> media, the dimensions are with the "times" character as you wish. Maybe the developers wanted to avoid special chars in window title. But in the title of this page, the "times" is left alone. So confirming.
Status: UNCONFIRMED → NEW
Component: General → Page Info
Ever confirmed: true
QA Contact: general → page.info
But seem to be a dupe of Bug 136556.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 136556
(In reply to aceman from comment #2)

> But seem to be a dupe of Bug 136556.
> 
> *** This bug has been marked as a duplicate of bug 136556 ***

Not entirely a duplicate. Non-breaking spaces, please. Thanks.
Ok, the "times" part is covered by Bug 136556.

This bug 677912 can stay for the "non-breaking spaces" part.
Status: RESOLVED → REOPENED
Component: Page Info → Localization
Keywords: intl, polish
OS: Windows XP → All
Product: Firefox → Core
QA Contact: page.info → localization
Hardware: x86 → All
Resolution: DUPLICATE → ---
Version: unspecified → Trunk
(In reply to aceman from comment #4)
> Ok, the "times" part is covered by Bug 136556.
> 
> This bug 677912 can stay for the "non-breaking spaces" part.

Seeing as how bug 136556 is still open, you can probably get it rescoped to include non-breaking spaces, if that is what is desired. There is likely no need for this additional bug.

Re-marking as dupe.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 136556
So, "times" is \u00d7 , non-breaking space is \u00A0 ?
www.fileformat.info/info/unicode/char/d7/index.htm
www.fileformat.info/info/unicode/char/A0/index.htm
Please verify with "Firefox/9.0a1 ID:20110911030845" that this report is fixed.
This bug is not an exact duplicate of the “times” part.

Aceman, I was suprised to see today this bug in fresh Firefox 23.0.1, on Mac. The letter “x” and the lack of spaces. Both in the window title and in the info window.

See these screen photos :
http://pbrd.co/16Sxr7h
http://pbrd.co/16SELzV
Status: RESOLVED → REOPENED
Depends on: 136556
Resolution: DUPLICATE → ---
Attached patch patchSplinter Review
Fix bug 136556 again, now also changing the string IDs so that localizers can see the change and update all the langpacks. Sorry this is not run-time tested as I do not build Firefox. Can somebody please do it?
Assignee: nobody → acelists
Status: REOPENED → ASSIGNED
Attachment #799039 - Flags: review?(bzbarsky)
Comment on attachment 799039 [details] [diff] [review]
patch

r=me
Attachment #799039 - Flags: review?(bzbarsky) → review+
Thanks.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/00209f73f7b6
Status: ASSIGNED → RESOLVED
Closed: 9 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla26
See also : 

Similar bug, but in the Inspector : bug 1042619.
You need to log in before you can comment on or make changes to this bug.