Last Comment Bug 677924 - JS shell: version(4096) asserts
: JS shell: version(4096) asserts
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Jason Orendorff [:jorendorff]
:
Mentors:
: 652806 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 08:50 PDT by Jason Orendorff [:jorendorff]
Modified: 2011-08-11 04:22 PDT (History)
3 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.88 KB, patch)
2011-08-10 09:35 PDT, Jason Orendorff [:jorendorff]
cdleary: review+
Details | Diff | Splinter Review

Description Jason Orendorff [:jorendorff] 2011-08-10 08:50:22 PDT

    
Comment 1 Jason Orendorff [:jorendorff] 2011-08-10 09:35:46 PDT
Created attachment 552098 [details] [diff] [review]
v1

http://quotes.burntelectrons.org/4833
Comment 2 Jason Orendorff [:jorendorff] 2011-08-10 09:37:22 PDT
The essential thing is to reject values >= 4096 with an exception; the rest is just me trying to get Version use the API correctly.

Incidentally that test where I added a Number() call was never doing what it thought it was doing, because version() would just ignore the string arguments.
Comment 3 Jan de Mooij [:jandem] (PTO until July 31) 2011-08-10 09:40:35 PDT
*** Bug 652806 has been marked as a duplicate of this bug. ***
Comment 4 Jason Orendorff [:jorendorff] 2011-08-10 15:52:00 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ae3174c57ff
Comment 5 Mounir Lamouri (:mounir) 2011-08-11 04:22:22 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/7ae3174c57ff

Note You need to log in before you can comment on or make changes to this bug.