The default bug view has changed. See this FAQ.

Add a --enable-webapi configure option

RESOLVED WONTFIX

Status

()

Core
Build Config
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 552097 [details] [diff] [review]
Patch v1
Attachment #552097 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Whiteboard: [needs review]
Why do we want this?
(Assignee)

Comment 2

6 years ago
To be able to push stuff in mozilla-central quite easily.
That approach would make it hard for people to test new APIs.  It's also not going to help keep the WIP code from rotting, since the MOZ_WEBAPI code would be invisible to patches landing on m-c.

I had an envisioned a workflow something like
 - iterate in bugs/patch queue/project branch until API X is ready for feedback
 - land on m-c, pref'd off
 - iterate moar until full spec and impl are done for X
 - pref on

What are the issues you see in an approach like that?
(In reply to Chris Jones [:cjones] [:warhammer] from comment #3)
> That approach would make it hard for people to test new APIs.  It's also not
> going to help keep the WIP code from rotting, since the MOZ_WEBAPI code
> would be invisible to patches landing on m-c.

Right, these are my concerns as well.
(Assignee)

Comment 5

6 years ago
What about changing MOZ_WEBAPI to MOZ_WEBAPI_EXPERIMENTAL and move stuff out of MOZ_WEBAPI_EXPERIMENTAL as soon as they are ready for feedback.

My main concern is that a project branch might be more annoying than helpful (at least for the moment).
My instinct is to not bother with MOZ_WEBAPI/MOZ_WEBAPI_EXPERIMENTAL until we run across cases where there's a bunch of code we want to land on m-c that's not at all ready for feedback.  I'm not really sure what that kind of code would look like.

What code would you want to land on a project branch initially, if one were created?
(Assignee)

Comment 7

6 years ago
I have some code to send SMS and place calls that is rotting in my patch queue.
I guess I should just keep it here then...
How will it be less rotting if we stick it in the tree but don't try to build or test it?
(Assignee)

Comment 9

6 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #8)
> How will it be less rotting if we stick it in the tree but don't try to
> build or test it?

Boilerplate code bitrotes quickly and that often requires to fix the local patch queue.
Though, I believe I'm quite alone to think it would help so I will just mark it as WONTFIX.
No longer blocks: 673923
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [needs review]
(Assignee)

Updated

6 years ago
Attachment #552097 - Flags: review?(khuey)
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WONTFIX → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.