Access bookmarks and history via add-on SDK methods

RESOLVED DUPLICATE of bug 545700

Status

RESOLVED DUPLICATE of bug 545700
7 years ago
7 years ago

People

(Reporter: d_jan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I want to create an add-on to (among other things) create bookmarks using the add-on SDK


Actual results:

the SDK does not provide methods to do so. 


Expected results:

Methods could provide simple access to the bookmarking and history functionalities.
You would have to be really careful with this so that the code wouldn't be executed each time the browser is started (and/or whenever the add-on is installed/upgraded).

Bug 545700 would allow you to do this, and it looks like there's a module listed at the end of the comments that would work right now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545700
You need to log in before you can comment on or make changes to this bug.